VectorLinux
November 28, 2014, 08:51:44 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Has anyone managed to build Sylpheed successfully in Vector 6.0 (any version)?  (Read 1808 times)
Colonel Panic
Vectorian
****
Posts: 526


« on: February 25, 2010, 01:48:37 pm »

Hi. I've been trying to compile Sylpheed in both Vector 6.0 Standard and 6.0 KDE Classic, but in each case I've had to admit defeat. The error message I keep getting when I try to use Sylpheed is as follows;

sylpheed: error while loading shared libraries: libsylpheed-plugin-0.so.0

cannot open shared object file: No such file or directory

This happens whether I'm trying to build and run Sylpheed 2.7.1 or 3.0.0 (the latest version).

It's not the end of the world as Sylpheed Claws 3.7.5 builds and runs fine in Vector 6.0 and does everything I need from an email program, but I'm curious as to what might be going wrong.

Has anyone got any ideas about this?

Thanks in advance,

Colonel Panic.
Logged
Pita
Vectorian
****
Posts: 1311


« Reply #1 on: February 25, 2010, 08:08:30 pm »

I am running Sylpheed 2.7.0 and will install soon version 3.0. I do not recall having had an
install problem. I do have that library:
$ locate  libsylpheed-plugin-0.so.0
/usr/local/lib/libsylpheed-plugin-0.so.0
/usr/local/lib/libsylpheed-plugin-0.so.0.0.0

Normally I am using Claws-mail, except when I have to use an external print command
a feature which got lost in claws-mail or I am unable to make it work unlike in previous versions
of claws-mail.
Logged
Pita
Vectorian
****
Posts: 1311


« Reply #2 on: February 26, 2010, 12:16:03 am »

I am running Sylpheed 2.7.0 and will install soon version 3.0. I do not recall having had an
install problem. I do have that library:
$ locate  libsylpheed-plugin-0.so.0
/usr/local/lib/libsylpheed-plugin-0.so.0
/usr/local/lib/libsylpheed-plugin-0.so.0.0.0

Normally I am using Claws-mail, except when I have to use an external print command
a feature which got lost in claws-mail or I am unable to make it work unlike in previous versions
of claws-mail.

I just installed sylpheed-3.0 and to run it I had to do "ldconfig" first as sudo otherwise
I got the same error you mentioned. In fact giving command:
"ldd /usr/local/bin/sylpheed|grep found"
showed it missed even 2 libraries. Not anymore after ldconfig.
Logged
Colonel Panic
Vectorian
****
Posts: 526


« Reply #3 on: February 26, 2010, 03:31:54 am »

Thanks for this, I'll give it a try soon.

Just one thing though; even in Sylpheed Claws I'm unable to send E-mails with SSL enabled. Normally it doesn't matter much but there are times when it might, so I'd like to get it fixed if possible.
« Last Edit: February 26, 2010, 08:37:02 am by Colonel Panic » Logged
Pita
Vectorian
****
Posts: 1311


« Reply #4 on: April 03, 2010, 08:15:58 pm »

Just installed Sylpheed-3.0.2. Went smooth and this time I had not to do ldconfig
to start it.
And true mail will not leave when SSL is checked to be used even when non-blocking
SSL is turned off as suggested.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!