VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Penguin Command and Frozen Bubbles - No video  (Read 2639 times)

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1331
Penguin Command and Frozen Bubbles - No video
« on: March 13, 2010, 07:41:02 am »

I suspect this is a driver issue, but I'll be dipped if I can figure it out. The notebook is a Toshiba P305D, ATI x1250 graphic chip set, 4GB Ram, and AMD 2GHz Turion 64 x2. I selected the Radeon driver on installation.

When selecting either game, I get a black screen. Sound works just fine, just no video. Suggestions? Should I have selected the ATI driver instead?
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Penguin Command and Frozen Bubbles - No video
« Reply #1 on: March 13, 2010, 12:20:47 pm »

It's worth a shot. My understanding is that the 'ati' driver is just a wrapper for other ati drivers and will, on-the-fly, select the appropriate ATI driver (r128, radeon, etc).  Give it a shot and see if it solves your problem - it shouldn't hurt.  You may also want to check the fps in glxgears before and after switching drivers just to see if it changes much.

Good luck!
Logged

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1331
Re: Penguin Command and Frozen Bubbles - No video
« Reply #2 on: March 13, 2010, 01:20:45 pm »

Didn't check FPS prior to redoing the driver. All I can say is this. I sure wish I got those kind of framerates in WoW and LOTRO!  ;D

As for the game issue.. No change. I'll do some more digging and see if I can find an error message buried somewhere that gives me a clue as to what's going on.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Penguin Command and Frozen Bubbles - No video
« Reply #3 on: March 13, 2010, 09:22:39 pm »

I've never tried Penguin Command, but I run Frozen Bubble a lot on my three systems.

If you start Frozen Bubble from a terminal prompt, do you get any messages? The command is
frozen-bubble

Two of my computers use the xorg radeon driver and the laptop uses the intel driver. You may find a bit of help at the Frozen Bubble Web site ( http://www.frozen-bubble.org/home/ ).
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1331
Re: Penguin Command and Frozen Bubbles - No video
« Reply #4 on: March 13, 2010, 10:43:17 pm »

Wierd... I made some big changes, so haven't had a chance to reinstall Frozen Bubbles, but here's the terminal results for Penguin Command.

** Starting SDL init **
** Init video **
** Set video mode **
** Create buffers **
** Finding Joysticks **
** Init joystick **
** Loading Title Screen **
** Opening Audio Mixer **
   8 channels allocated
** Loading Music **
** Loading Sounds **
** Playing Music **
** Ready to enter Menu **
Now playing song #1
** Fade in Music **
** Showing Title Screen **
** Blit Background **
** Background image drawn **
** Loading Font **
** Init Font **
** Loading Images **

And that's where it stays. Suspect I'd see something similar with Frozen Bubbles (I'll double check once it's reinstalled.).
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1331
Re: Penguin Command and Frozen Bubbles - No video
« Reply #5 on: March 14, 2010, 09:44:42 am »

It's a permission issue somewhere. I opened a terminal and su'd to root, then typed frozen-bubble. Worked like a champ. Doing some more digging. :)

And while at root, I tried penguin-command and finally got an error.

Warning: I could not open the options file for read:
/root/.penguin-command

Now I have some clues.  ;D
« Last Edit: March 14, 2010, 09:47:17 am by retired1af »
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz