Please support VectorLinux!

Author Topic: How To Upgrade FireFox on VL 5.8 [SOLVED]  (Read 3328 times)

solex

  • Member
  • *
  • Posts: 67
How To Upgrade FireFox on VL 5.8 [SOLVED]
« on: March 14, 2010, 02:11:16 pm »
Any help would be appreciated. 

I do not want to go through the trouble of installing VL 6.0 on my computer at this time as it will be time consuming as I use it as my main file server and backup server for a small windows network.

Support for FF 2.0 is just about down and am getting warnings from Google and YouTube that it will not longer be supported.

« Last Edit: March 17, 2010, 06:25:31 pm by solex »

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1280
Re: How To Upgrade FireFox on VL 5.8
« Reply #1 on: March 14, 2010, 03:40:41 pm »
Add the testing directory to your preferences in GSLAPT and you should find FF 3.5
ASUS K73 Intel i3 Dual Core 2.3GHz

solex

  • Member
  • *
  • Posts: 67
Re: How To Upgrade FireFox on VL 5.8
« Reply #2 on: March 14, 2010, 03:55:59 pm »
Hi,
I have ftp://ftp.osuosl.org/pub/vectorlinucx/veclinux-5.8/testing as a package source

The only thing I see is mozilla-firefox 3.03-i686-1vl58 location is ./net is this the correct package?

Thanks,
Dan

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: How To Upgrade FireFox on VL 5.8
« Reply #3 on: March 14, 2010, 04:28:35 pm »
VL5.8 is a bit old and I believe no one is packaging updated version of FF for it. I would suggest upgrade to a newer version of VL or you compile FF by yourself.

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1280
Re: How To Upgrade FireFox on VL 5.8
« Reply #4 on: March 14, 2010, 05:02:12 pm »
Hi,
I have ftp://ftp.osuosl.org/pub/vectorlinucx/veclinux-5.8/testing as a package source

The only thing I see is mozilla-firefox 3.03-i686-1vl58 location is ./net is this the correct package?

Thanks,
Dan

My bad. I clicked on 5.9 instead of 5.8 when checking the repository.

Yeah... Your best bet would be to download directly from Firefox and install that way. It's not that bad.  ;D
ASUS K73 Intel i3 Dual Core 2.3GHz

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: How To Upgrade FireFox on VL 5.8
« Reply #5 on: March 14, 2010, 05:29:26 pm »
IIRC, you can run firefox as root and then access the Help/Update option which will update the version installed on your system.  I seem to remember the potential for broken plugins but can probably be fixed after-the-fact.  Hope this helps.

solex

  • Member
  • *
  • Posts: 67
Re: How To Upgrade FireFox on VL 5.8
« Reply #6 on: March 14, 2010, 07:33:23 pm »
Thanks Guys,

I know this is a long shot but I don't want to waste your time and hear you that I should upgrade but I downloaded Firefox and get the following error:

//home/blah/firefox/firefox-bin: error while loading shared libraries: libdbus-1.so.3: cannot open shared object file: No such file or directory

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: How To Upgrade FireFox on VL 5.8
« Reply #7 on: March 15, 2010, 01:29:49 am »
What version of dbus currently installed on your system?

solex

  • Member
  • *
  • Posts: 67
Re: How To Upgrade FireFox on VL 5.8
« Reply #8 on: March 15, 2010, 05:09:01 pm »
I have version 0.62-i586-4v58

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: How To Upgrade FireFox on VL 5.8
« Reply #9 on: March 15, 2010, 05:29:28 pm »
I think u need dbus version 1.x or above....try search the VL repo for any update..but I dun think there is any recent update to VL 5.8 repo as it is no more maintained..............if there is no you have to manual compile it yourself..

solex

  • Member
  • *
  • Posts: 67
Re: How To Upgrade FireFox on VL 5.8
« Reply #10 on: March 17, 2010, 06:25:15 pm »
I can't believe it but I got it to work.  Thanks to the suggestions.

I upgraded to dbus 1.02
Then when I ran FF 3.6 it told me I needed gtk 2.10 or higher (I had 2.8 installed)
I then upgraded gtk-engines to version 2.10.


Ho do I replace my current version of FireFox to I simply replace some directory if so where do I find it?

Thanks Again....
Dan
« Last Edit: March 17, 2010, 06:32:12 pm by solex »

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: How To Upgrade FireFox on VL 5.8 [SOLVED]
« Reply #11 on: March 18, 2010, 03:12:36 am »
use removepkg to remove the current version and compile the latest version of FF..

solex

  • Member
  • *
  • Posts: 67
Re: How To Upgrade FireFox on VL 5.8 [SOLVED]
« Reply #12 on: March 18, 2010, 05:15:55 am »
hata_ph

The package is already compiled, I un-tarred it to a directory and it works as is, why would I need to recompile?

Thanks
Dan

hata_ph

  • Packager
  • Vectorian
  • ****
  • Posts: 3261
  • -- Just being myself --
Re: How To Upgrade FireFox on VL 5.8 [SOLVED]
« Reply #13 on: March 18, 2010, 07:26:20 am »
Haha...sorry..maybe I misunderstand your post.... :P

solex

  • Member
  • *
  • Posts: 67
Re: How To Upgrade FireFox on VL 5.8 [SOLVED]
« Reply #14 on: March 19, 2010, 11:58:51 am »
I'm good for now I simply moved the folder to //usr/lib/firefox/ and remove the firefox 2.0 package and created one symlink on my desktop to the new folder for firefox and the startup script.
« Last Edit: March 22, 2010, 04:32:32 am by solex »