VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Belkin F5D7010 v.1 (BCM 4306) Wireless problem  (Read 1605 times)

sony_vaio_user

  • Member
  • *
  • Posts: 3
Belkin F5D7010 v.1 (BCM 4306) Wireless problem
« on: March 19, 2010, 10:51:52 am »

Hi,

Wasn't sure whether to post this here or in the Vectorbie's forum, but anyhow hopefully the admins will sort that. Please be gentle I'm new to all this!

My problem. I have installed Vector Linux 6 Light onto my Sony Picturebook (PCG-C1MHP) and have been trying to get my Belkin F5D7010 v.1 (BCM 4306) PCMCIA wireless adapter to work. My wireless router uses WPA-PSK for encryption.

I followed the excellent guides on using ndiswrapper and have the card enabled and am able to see wireless networks. However, I cannot connect to any of them. When I first brought WLAN0 up after the initial set-up it was fine, ran Vlwifi and it connected first time, I then shutdown the machine and it hasn't connected since.

Any ideas?

Thanks,

Peter.
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Belkin F5D7010 v.1 (BCM 4306) Wireless problem
« Reply #1 on: March 19, 2010, 11:08:38 am »

Have you tried setting up your network connection using Wicd Network Manager? It should be found in your menu under Network(ing).

A side note: My laptop has a linksys pcmcia (broadcom) chipset. I think it's even BCM 4306.  I use the linux b43 drivers rather than ndiswrapper - it's pretty smooth.  However, if you already have ndiswrapper working then I'd suggest sticking with it.
Logged

sony_vaio_user

  • Member
  • *
  • Posts: 3
Re: Belkin F5D7010 v.1 (BCM 4306) Wireless problem
« Reply #2 on: March 19, 2010, 11:13:54 am »

Yes I've tried Wicd and it just says "validating authentication" and fails.

Oh, I checked and thought the b43 driver wouldn't work with my card.

Logged

sony_vaio_user

  • Member
  • *
  • Posts: 3
Re: Belkin F5D7010 v.1 (BCM 4306) Wireless problem
« Reply #3 on: March 19, 2010, 05:01:22 pm »

Okay, following on from Newt's comments about using the native driver and a little digging I've realised that I had not run through the How-To properly. As I hadn't got any personal data on the laptop I decided to re-install Vector and try from scratch again following the instructions exactly. What I'd missed was running vasm and doing the hardware stuff. In doing this it immediately kicked the card into life and I was able to connect straight away and has even remained after a reboot. Many thanks Newt for your advice!
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Belkin F5D7010 v.1 (BCM 4306) Wireless problem
« Reply #4 on: March 19, 2010, 08:14:42 pm »

I'm glad you got it sorted. I'm not sure if I helped much, but if a simple reinstall got things going correctly then it was probably worth the extra effort.  Glad you were able to get it figured out.

Cheers!
Logged