Please support VectorLinux!

Author Topic: Printing problem  (Read 1422 times)

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Printing problem
« on: April 15, 2010, 11:57:11 am »
Having successfully got access to my printer from Cups, I was able to print a test page, which worked fine. So I thought I was all set. Oh well, nothing like being optimistic I guess....

Anyhow, today I attempted to print a document from OpenOffice on my T61 to the Brother printer (which is attached to my Amahi server). Failed. Tried from mousepad. Which also failed.

I've been looking through the Cups interface. Since it seemed to be a permission problem (and, so far as I can tell, is on the local box, not the server), I thought I would check what users are allowed. So I went to Manage Printer, and clicked on the 'Set allowed users' button. Which gets me a 403 Forbidden error.

The printing problem seems to have solved itself (wish I knew why), but I'm puzzled as to why I don't seem to be able to set allowed users. I'm also puzzled by the fact that there doesn't seem to be any option to log into Cups - I thought there was when I first used it.

I'm about to go searching for clues, but I'm wondering if anyone knows what I'm doing wrong....

Paul.
 

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Printing problem
« Reply #1 on: April 15, 2010, 12:00:33 pm »
Are you accessing CUPS through your browser as root?
--GrannyGeek
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

toothandnail

  • Tester
  • Vectorian
  • ****
  • Posts: 2527
Re: Printing problem
« Reply #2 on: April 15, 2010, 12:06:18 pm »
Are you accessing CUPS through your browser as root?
--GrannyGeek


:) Good question. I think so. I'm accessing Cups through VasmCC, which requires the root password to start, so I hope I'm set as root for the operation.

I've not tired su and start the browser, but I guess that might be the next step.

Paul.