VectorLinux
November 01, 2014, 03:26:02 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: strange application style  (Read 933 times)
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« on: April 17, 2010, 12:11:10 pm »

I've just installed VL6.0 SOHO KDE-Classic and I noticed that all non-KDE applications have this strange, hard, blocky looking interface style as seen in the Gslapt screenshot below. What can I do to fix this? With VL5.9.1 SOHO, I had a much nicer, rounded look to all these applications.

Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #1 on: April 17, 2010, 07:16:55 pm »

Open Control Center, go to Appearance & Themes. Test out different themes and styles. You can find a lot more here: http://kde-look.org/
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #2 on: April 18, 2010, 10:43:37 am »

Yeah, I looked at that but there isn't any style in there that corresponds to what I see in all the non-KDE apps. All the KDE apps use the styles and themes selected in the control center but all the non-KDE apps don't. I think the style that I'm seeing is the default gtk theme maybe? I'm thinking that something is wrong with Qt or GTK settings. In 5.9.1, there was a place in the control center under appearance and themes that was called Gtk Styles and Fonts or something like that. There, I could change whether or not non-KDE applications used the KDE styles. I haven't been able to find anything like that now. Is there a way to do something about that?
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #3 on: April 18, 2010, 02:06:46 pm »

Try "GTK Theme Switcher" on the Menu under "Settings".
Logged
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #4 on: April 18, 2010, 04:09:46 pm »

Hmm... The Gtk Theme Switcher can show a preview of the themes (an example application window with the widget styles applied) and it shows it exactly like I saw things in 5.9.1. It's just the preview window that's correct though. Everything else stays the same no matter what I switch the theme to.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
Daniel
Packager
Vectorian
****
Posts: 704


WWW
« Reply #5 on: May 01, 2010, 01:17:58 pm »

I looked at a virtual installation of KDE-Classic that I had and it has no problems at all with gtk apps. I think the reason I have problems with this installation is that I used the same /home directory/partition as the previous 5.9.1 installation. Some carried over configuration files are probably messing it up. The question asked in this thread is solved now though.
Logged

The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!