VectorLinux
October 01, 2014, 12:08:59 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Sharing files between VL6 gold box and mainly windows network  (Read 1585 times)
wannaspeedcom
Member
*
Posts: 14


« on: April 18, 2010, 06:31:32 pm »

I just got into the linux thing. I have VL6 gold installed on an older computer which really brought some speed out of it. The problem is I can't for the life of me figure out how to share files through samba and such. I've tried various settings but nothing is working yet.

I downloaded the thunar share tab plugin package, following the "how to" to a T, I installed it just as was said, but it will not show the extra tab in the folder I create. I made sure it is my folder, and I tried restarting, even formatted the drive and started all over.

Next problem I faced is the samba doesn't seem to work right. When I open a terminal and run vlsmbmnt from root it comes back with this error. I found a video how to on fixing it, followed the extremely well layed out video to a T including installing "bind" and I still get the same error! I don't know what is going on, I can find at least some issues yet all the workarounds aren't working correctly for me. Here is the video I followed. http://www.opensourcebistro.com/Tutorial/VL60/Trouble-Shooting/sambafix/sambafix.htm

In puppy linux I was able to figure out file sharing in a couple minutes, I've been working on trying to share files ALL day in vector. I do like the vector layout better though. Anyway, please help.
Logged
wannaspeedcom
Member
*
Posts: 14


« Reply #1 on: April 18, 2010, 08:23:33 pm »

I got it!

I downloaded the vlsmbmnt update files from the test server as well as an updated sambda package. I don't know which fixed it, but I can now browse my windows files. Haven't yet tried to work from windows to see if I can see my linux computer but at least my main issues are solved.
Logged
wannaspeedcom
Member
*
Posts: 14


« Reply #2 on: April 18, 2010, 08:36:54 pm »

The thunar plugin still doesn't work. And I can see my linux network from my XP computer and when I click on it it asks for a username and password, but nothing I think to enter works..... Any ideas?
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: April 18, 2010, 08:39:33 pm »

If you have not set a user name and password, then you can just leave it blank and press enter.  This is true for all three times you are asked for a user name or password.
« Last Edit: April 18, 2010, 08:41:28 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
wannaspeedcom
Member
*
Posts: 14


« Reply #4 on: April 18, 2010, 09:22:04 pm »

It wouldn't let me click "ok" in windows with a blank field. I did fix my problem though. In terminal I under root permissions I added

smbpasswd -a username
password
password

(with username being my username and my password entered twice)

Then on the XP machine I used the same username and password.

I would still like to get that "share tab" plugin working, but this works for now.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #5 on: April 18, 2010, 11:19:43 pm »

Thanks for bringing those gslapt downloads to my attention.  I've updated the Opensourcebistro tutorial to reflect.
http://www.opensourcebistro.com/blog1/?p=442

Glad you got it working.  I don't actually have a Windows machine on my network, so I wasn't quite sure where you were getting the password problem.
Ken
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
wannaspeedcom
Member
*
Posts: 14


« Reply #6 on: April 19, 2010, 07:49:43 pm »

Cool glad I could be of help. Wish I had that video when I was trying to get mine working lol. I'm trying to get away from windows myself, I've only been messing with linux for a couple days now, I really like all the options available. I still have to keep windows at least until I find suitable replacment apps for linux. I do wish I could figure out how to get that plugin for thunar working. That seems like a nice easy way of sharing additional folders without going through the samba setup.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!