Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Auto wifi network connection in VL 6.0  (Read 744 times)


  • Member
  • *
  • Posts: 1
Auto wifi network connection in VL 6.0
« on: April 21, 2010, 10:37:44 am »

Hi I am a VL and linux newbie.  I managed to hd install VL 6.0L with Icewm?, to my HP mini note 2133.  I have wifi up, my card recognized and can connect to networks with WPA, thanks Vector!!!  If I could do it any newb can use vl with a little patience.
Now I am spoiled, and want to get my wifi to auto run and try to connect to stored networks.  I don't know how to do this.  I read 6.0 manual but it is beyond my technical ability.  Is this possible so that wifi will does not have to be manually started and connected everytime.  My broadcom b43 card is working great with vl.  VLwifi option in menu does not do anything that I can see.  Wicd is the way I get connected.  Can I get wicd to start with boot, is that what a deamon does?
Thanks for great distro!
By the way, my webcam works! No other distro I tried did that.


  • Administrator
  • Vectorian
  • *****
  • Posts: 1352
Re: Auto wifi network connection in VL 6.0
« Reply #1 on: April 21, 2010, 12:09:42 pm »

Wicd should have an option to automatically connect when you start it. You're not seeing that option?
ASUS K73 Intel i3 Dual Core 2.3GHz


  • Vectorian
  • ****
  • Posts: 636
  • move the needle
Re: Auto wifi network connection in VL 6.0
« Reply #2 on: April 21, 2010, 04:00:54 pm »

Sorry, I missed the "L" in "VL 6.0L" the first time around, or would've responded already.

You're correct, wicd does need daemon for this. The point-and-click way is:

"Start" > System > VASM > Super > SERVICE > SRVSET   select a run level (usually 4, sometimes 2, can be both) and check wicd. If you only want wicd in gui, you don't need it in 2; if you want it in 2, you still have to select it for 4 also if you want it there. Vector stops services not requested in the next runlevel in a way different from many distros.

That got you the daemon (well, it will if you reboot or re-enter level 4). Now the client. I've upgraded wicd from the testing repository; the new name for client is "wicd-gtk". Sorry, but I can't recall the old name - it may be "vwicd-client". Find out for sure by doing: locate wicd | grep bin    to see if it's there. If you haven't upgraded, substitute the correct name for "wicd-gtk" in the line below and put it near the bottom of ~/.icewm/startup. Include the "&" so startup won't stop there.

Code: [Select]
sleep 2
#above line may be optional - use it if you have trouble without it

If you restart, the daemon will start when X does, the client will start with your session. The first time, check the "connect automatically" box and connect to the desired AP. From then on, the connection should be fully automatic. If this doesn't work, please post back.

When the wicd upgrade moves to regular repo, or if you decide to get it from testing, the name change causes a harmless duplication in menus. The fix is here:

Light's a little more work than the others, but not much more. If you chose light in the first place, you'll be happy with the return on your effort.
VL 7.1 Light