VectorLinux
April 19, 2014, 01:05:50 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: fresh install and gslapt fine, new kernel kills video  (Read 1740 times)
Deach
Vectorite
***
Posts: 168


« on: April 24, 2010, 08:30:46 am »

Ok installed Vector on laptop number 2.  All went exactly as expected.  Gslapt updated fine.  I updated the kernel (as per instructions) and when i rebooted it goes to the login screen, but, after logging in it just goes to a solid blue screen and no icons appear no mouse pointer etc.  I can provide whatever info is needed but if anyone maybe had this on this video card, I'd appreciate some help. 
Code:
VGA compatible controller: Intel Corporation Mobile 915GM/GMS/910GML Express Graphics Controller (rev 03)

Thanks,
Deach
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
hata_ph
Packager
Vectorian
****
Posts: 3206


-- Just being myself --


« Reply #1 on: April 24, 2010, 09:21:47 am »

Can you log to TUI and type startx to bring up the GUI?
Logged
Deach
Vectorite
***
Posts: 168


« Reply #2 on: April 24, 2010, 09:47:48 am »

no, I haven't removed the old kernel yet and booting to "tui" is still using the old kernel.  so yes start x works. (old kernel).  I guess I could remove the old kernel and give this a go but I had no such problems on my much older machine.  I'll keep trying things though....Thanks

Deach
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
hata_ph
Packager
Vectorian
****
Posts: 3206


-- Just being myself --


« Reply #3 on: April 24, 2010, 04:04:06 pm »

When you install a new kernel there is a option for the new kernel when you booting the system. Edit your lilo.conf to enable TUI option for your new kernel, then try startx in your new kernel..
Logged
Deach
Vectorite
***
Posts: 168


« Reply #4 on: April 24, 2010, 04:54:28 pm »

Not exactly sure on where lilo.conf is or editing it.  A little "more" please?  I'm certainly willing to try.  Thanks
Deach
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
retired1af
Packager
Vectorian
****
Posts: 1221



« Reply #5 on: April 24, 2010, 04:59:27 pm »

lilo.conf is in /etc

Ensure you su to root prior to editing the file.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
roarde
Vectorite
***
Posts: 488


move the needle


« Reply #6 on: April 24, 2010, 05:15:55 pm »

Yep, it's /etc/lilo.conf. (like retired1af needs my seconding Cheesy)

I recently installed a new kernel, 2.6.31.8. Here's the relevant portion of my lilo.conf:
Code:
# Partition 4: Linux
image = /boot/vmlinuz-2.6.31.8
    root = /dev/sda2
    label = 2.6.31.8
    append = "splash=silent "
    read-only

The initrd line does not appear. I think changing this entry to two entries like these is what's being suggested:
Code:
# Partition 4: New Kernel, GUI
image = /boot/vmlinuz-2.6.31.8
    root = /dev/sda2
    label = 2.6.31.8-gui
    append = "4 splash=silent "
    read-only
# Partition 5: New Kernel, TUI
image = /boot/vmlinuz-2.6.31.8
    root = /dev/sda2
    label = 2.6.31.8-tui
    append = "2 splash=silent "
    read-only

Not sure what to do about initrd, maybe we'll both get some help.

It's the number on the append = line that tells the kernel what runlevel to boot to. In VL, 2 is user tui, 4 is user gui.

After editing, run lilo. That installs your changes to the bootfile location.
Logged

Robert
VL Light 7.0, icewm/spacefm
Deach
Vectorite
***
Posts: 168


« Reply #7 on: April 25, 2010, 07:26:24 am »

ok now vliloconf isn't even finding the new kernel.? Huh Huh  should I remove it and reinstall or what here? I downloaded it, right clicked on 'instal package" and it simply isnt' there??? Huh  Um I'm so confused now......
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
retired1af
Packager
Vectorian
****
Posts: 1221



« Reply #8 on: April 25, 2010, 07:56:00 am »

I find the easiest way to apply new kernel changes to LILO is to run the boot loader configuration via VASMCC after the new kernel is built. It should find everything and include both kernels in your lilo.conf file. Then it's just a matter of creating a TUI entry for the entries you wish to include.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Deach
Vectorite
***
Posts: 168


« Reply #9 on: April 25, 2010, 07:57:54 am »

ok I'll try vasm.  I did this on my older laptop with out a hitch.  I'm a little aloof as to what's going on here.  Thanks for keeping with me here.
Deach

EDIT:  No change trying it thru vasm new kernel still not there...........need emoticon of guy banging his head against the wall


« Last Edit: April 25, 2010, 08:04:25 am by Deach » Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
Deach
Vectorite
***
Posts: 168


« Reply #10 on: April 25, 2010, 08:15:30 am »

neither Vasm CC or vliloconf is finding the new kernel (2.6.31.Cool  I'm clueless here.  it'snot possible for me to edit the lilo.conf file without that there I don't think....
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
retired1af
Packager
Vectorian
****
Posts: 1221



« Reply #11 on: April 25, 2010, 09:31:34 am »

List the contents of your /boot directory please.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Deach
Vectorite
***
Posts: 168


« Reply #12 on: April 25, 2010, 09:46:32 am »

Code:
Vector://boot
user:$ ls
MBR.042310           boot.0300        diag1.img  slack.bmp
System.map@          boot.label       grub/      tamu/
System.map-2.6.31.8  config@          initrd     vmlinuz@
bitmap/              config-2.6.31.8  map        vmlinuz-2.6.31.8
 
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
retired1af
Packager
Vectorian
****
Posts: 1221



« Reply #13 on: April 25, 2010, 09:58:25 am »

What's in /boot/tamu?
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Deach
Vectorite
***
Posts: 168


« Reply #14 on: April 25, 2010, 10:00:39 am »

that is empty I got no return.
Code:
Vector://boot/tamu
user:$ ls
Vector://boot/tamu
 
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!