Please support VectorLinux!

Author Topic: Something about ATI X1250 using proprietary drivers?  (Read 1679 times)

mopac

  • Member
  • *
  • Posts: 6
Something about ATI X1250 using proprietary drivers?
« on: April 26, 2010, 06:47:18 am »
Hello!

I have been searching in the forum, and I could see that there are people using ATI X1250 onboard  graphic card.
I am wondering if there is a howto somewhere to make propietary drivers to work in Vector 6.0 KDE-Clasic.

The installation process goes without errors, but the X never appeared again after reboot. Is it a mistake of Vector? I have read a lot about entering in text mode and running some utility like vasm. Perhaps to go back to the initial configuration, but I wondering about a regular way like post install doing #aticonfig --initial? and you have 3D. 
 

I think this is a fantastic forum, I have read very interesting answers here.
Cheers

Mopac
 
« Last Edit: April 27, 2010, 09:47:49 am by mopac »

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1280
Re: Something about ATI X1250 using proprietary drivers?
« Reply #1 on: April 28, 2010, 02:58:42 pm »
OK. Installing the driver is pretty easy and straight forward.

Fire up gslapt and download/install vlati.

Once it's finished, open a terminal and type vasm. Select Super Vasm (enter root password).

Select xwindow

Select xconf

Select vxconf

You'll be presented with a list of options, select fglrx. This will kick off the ATI installer. Select Install driver 8.56.1 and follow the prompts.

Once it's all finished, you'll finish out the xwindow configuration. Once finished, close all that and you should see the ATI options in the KDE menu.

Enjoy...

Whups.. Almost forgot. You can edit your settings by running aticonfig in terminal. :)
« Last Edit: April 28, 2010, 03:05:29 pm by retired1af »
ASUS K73 Intel i3 Dual Core 2.3GHz

retired1af

  • Packager
  • Vectorian
  • ****
  • Posts: 1280
Re: Something about ATI X1250 using proprietary drivers?
« Reply #2 on: April 28, 2010, 07:14:24 pm »
Also found this: http://www.backtrack-linux.org/forums/old-bt3beta-bugs-fixes/7516-ati-radeon-graphics-newer-chipsets-fixed-my-x1250-graphics.html

Gives some extra insight on how to activate the shared memory abilities of the chipset.
ASUS K73 Intel i3 Dual Core 2.3GHz

mopac

  • Member
  • *
  • Posts: 6
Re: Something about ATI X1250 using proprietary drivers?
« Reply #3 on: May 13, 2010, 06:57:57 am »
Thanks a lot retired1af  very very helpful!!!