VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: VL 6.0 KDE classic wifi problem [SOLVED]  (Read 1894 times)

stolpiller

  • Member
  • *
  • Posts: 23
VL 6.0 KDE classic wifi problem [SOLVED]
« on: May 07, 2010, 08:53:55 am »

Hello

My wifi card is detected (lspci shows it), and the right modules ar loadded (lsmod shows iee80211).
But still VASM says wlan0 no such interface / no wireless interface...

Tried to do all in the guide here on VL. But i'm stuck :(

Computer IBM R51 and Intel ProW 2200BG

Thanks in advance
« Last Edit: May 08, 2010, 06:28:32 am by stolpiller »
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: VL 6.0 KDE classic wifi problem
« Reply #1 on: May 07, 2010, 09:36:37 am »

Can you provide the output from the following:
ifconfig -a
iwconfig
lspci
lsmod

I think iee80211 is a "helper" module but not the actual chipset module which is why it would be good to see the entire list of modules (lsmod).
Logged

stolpiller

  • Member
  • *
  • Posts: 23
Re: VL 6.0 KDE classic wifi problem
« Reply #2 on: May 07, 2010, 06:21:13 pm »

Ok, here we go....

ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:11:25:49:26:f4
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 00:12:f0:6a:2b:b9
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:4374 errors:0 dropped:0 overruns:0 frame:0
          TX packets:292 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:11 Base address:0x8000 Memory:d0204000-d0204fff

irda0     Link encap:IrLAP  HWaddr 00:00:00:00
          NOARP  MTU:2048  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:8
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)


iwconfig
lo        no wireless extensions.

irda0     no wireless extensions.

eth0      no wireless extensions.

eth1      unassociated  ESSID:off/any
          Mode:Managed  Channel=0  Access Point: Not-Associated
          Bit Rate:0 kb/s   Tx-Power=20 dBm   Sensitivity=8/0
          Retry limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
          Link Quality:0  Signal level:0  Noise level:0
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0


lspci (truncated)

02:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG Network Connection (rev 05)

lsmod (truncated)
ieee80211              28488  1 ipw2200
ieee80211_crypt         5380  1 ieee80211

Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: VL 6.0 KDE classic wifi problem
« Reply #3 on: May 07, 2010, 07:56:29 pm »

The wireless interface name is eth1 not wlan0. In VASM try using eth1 vs wlan0.

Bigpaws
Logged

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: VL 6.0 KDE classic wifi problem
« Reply #4 on: May 07, 2010, 07:58:54 pm »

It looks like your hardware is present and recognized by the system.  I'm not familiar with the KDE Classic variation of VL, but most likely it has the wicd network manager included.  I would use the wicd client to set up your network connection. Make sure you're using eth1 as your device name rather than wlan0.  Recollection tells me that either the default wicd or wpasupplicant device name is 'wlan0' which means you should check all Preferences of wicd, and if you use wpasupplicant then check it's settings (from within wicd) as well.  Let us know how it comes along.
Logged

stolpiller

  • Member
  • *
  • Posts: 23
Re: VL 6.0 KDE classic wifi problem
« Reply #5 on: May 08, 2010, 02:14:22 am »

The wireless interface name is eth1 not wlan0. In VASM try using eth1 vs wlan0.

Bigpaws

Confusing, with the naming... Anyways, tried eth1, in vasm. Seems now interface is correct, but i'm not connected... must be some other settings. Read last night that, with this machine, 1M Fixed rate, is a must... So i'll try different settings and see what happens :)
Logged

stolpiller

  • Member
  • *
  • Posts: 23
Re: VL 6.0 KDE classic wifi problem
« Reply #6 on: May 08, 2010, 02:23:44 am »

It looks like your hardware is present and recognized by the system.  I'm not familiar with the KDE Classic variation of VL, but most likely it has the wicd network manager included.  I would use the wicd client to set up your network connection. Make sure you're using eth1 as your device name rather than wlan0.  Recollection tells me that either the default wicd or wpasupplicant device name is 'wlan0' which means you should check all Preferences of wicd, and if you use wpasupplicant then check it's settings (from within wicd) as well.  Let us know how it comes along.
Wicd is run within KDE? I think kde-classic is just about the same as free SOHO (when 6.0 version is out), but with KDE 3.5
Ok, I will try that and present the results... :)


EDIT:::: Working now! Strange I could not get the network up in VASM. But worked in Wicd (figured out the dark arrow to add encryption, with some help from google).
I guess I only have wireless working within KDE?

Thanks for help guys!
« Last Edit: May 08, 2010, 04:02:14 am by stolpiller »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4141
Re: VL 6.0 KDE classic wifi problem
« Reply #7 on: May 08, 2010, 06:04:40 am »

Wicd is included and activated in KDE-Classic because it makes network configuration easy. However, you don't need wicd, or KDE. Manual configuration is a little more involved, you would need to disable the wicd service (use vasm), stop the wicd client from launching, and run "VLwifi" as root.
Logged

stolpiller

  • Member
  • *
  • Posts: 23
Re: VL 6.0 KDE classic wifi problem
« Reply #8 on: May 08, 2010, 06:28:09 am »

Wicd is included and activated in KDE-Classic because it makes network configuration easy. However, you don't need wicd, or KDE. Manual configuration is a little more involved, you would need to disable the wicd service (use vasm), stop the wicd client from launching, and run "VLwifi" as root.
First time using wifi under linux, glad it works. But wich is to prefer? Manual or via KDE? I'm thinking of major upgrades (new kernel, etc).. then I guess it's safe to be at runlevel 2?
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: VL 6.0 KDE classic wifi problem [SOLVED]
« Reply #9 on: May 08, 2010, 07:19:57 am »

You can use any Window Manager/Desktop environment for Wicd. It is a
gui front end for wireless tools.

As far as preference it does not make a difference. Wicd is designed
to make setting up wireless easier. VASM does the same thing as
WICD, in that it calls the same commands.

The gui interface (Window Manager/Desktop Environment) as all
front ends to the Command Line.

You do not need a gui to do anything in Linux. 

Bigpaws
« Last Edit: May 08, 2010, 07:24:06 am by bigpaws »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4141
Re: VL 6.0 KDE classic wifi problem
« Reply #10 on: May 08, 2010, 08:21:46 am »

wich is to prefer? Manual or via KDE?

If it is working for you now, leave it as it is.
Logged

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1342
Re: VL 6.0 KDE classic wifi problem
« Reply #11 on: May 08, 2010, 08:30:52 am »

If it is working for you now, leave it as it is.

Let's get real here! Leaving it alone is akin to telling a Harley rider to stop tinkering with his bike. It can't be done!  ;D
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

stolpiller

  • Member
  • *
  • Posts: 23
Re: VL 6.0 KDE classic wifi problem
« Reply #12 on: May 09, 2010, 03:53:44 am »

If it is working for you now, leave it as it is.

Let's get real here! Leaving it alone is akin to telling a Harley rider to stop tinkering with his bike. It can't be done!  ;D

Haha, yeah that's exactly what I mean! :D
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: VL 6.0 KDE classic wifi problem
« Reply #13 on: May 09, 2010, 12:33:46 pm »

I'm thinking of major upgrades (new kernel, etc).. then I guess it's safe to be at runlevel 2?

I use runlevel 2 for all my versions of VectorLinux. I prefer it because when I exit the desktop, I'm back at a command prompt and don't have to do tricks to get into an environment where X is not running. It's just one additional step at startup (type startx or startxfce4 or whatever command starts the desktop environment I want to use).
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller