VectorLinux
November 28, 2014, 07:27:12 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HP F4440 (xsane cannot find device)  (Read 2392 times)
dawnsboy
Vectorite
***
Posts: 135



« on: May 13, 2010, 07:55:01 am »

I have a copy of VL 6.0 light installed a mini pc with an Intel board featuring a 1.2GHz Intel Celeron 220.  I have been quite successful setting up CUPS to print to this printer.  However xsane reports device not found.  I used the f4213 ppd with the default install of hplip initially.  I upgraded to the 3.9.6 version via gslapt.  I added the ppd file from the f4400 series.  Prints quite well but still xsane cannot find a device.

I removed hplip altogether and manually deleted newly created directories.  I then downloaded and compiled hplip 3.9.6 with scan support enabled.  I setup the printer in CUPS with the f4400 series ppd.  Test prints wonderfully but xsane still reports no device found.

How do I get the scanner working on VL?  What have I overlooked?
Logged

Custom Mini-Itx - VL6.0 Light
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: May 13, 2010, 01:11:48 pm »

Do you get the same result when you start up the hp device manager and choose the 'Action' tab then start up scanning?
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
dawnsboy
Vectorite
***
Posts: 135



« Reply #2 on: May 13, 2010, 04:18:00 pm »

Quote
Do you get the same result when you start up the hp device manager and choose the 'Action' tab then start up scanning?

Yes.   Thank you for responding.
Logged

Custom Mini-Itx - VL6.0 Light
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #3 on: May 13, 2010, 07:09:40 pm »

Have you done su to root and typed
sane-find-scanner
at a terminal prompt? I don't think xsane will find your scanner if sane-find-scanner can't find it. If the scanner is found, note how it is seen as /dev. You may have to change permissions for the device in /dev so that your account (or the users group) can access the scanner. I've run into that issue every time with one of my scanners. Once you change the permissions (if needed), try xsane again as user.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #4 on: May 13, 2010, 08:34:26 pm »

Try this link to the 'how to's' it just might do the trick...
http://forum.vectorlinux.com/index.php?topic=8497.msg57608#msg57608
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
dawnsboy
Vectorite
***
Posts: 135



« Reply #5 on: May 15, 2010, 05:19:07 am »

Granny Geek said:

Quote
Have you done su to root and typed
sane-find-scanner

Yes I have.  Doing so returns a message that states device found and lists the location as libusb:001:002

Message also states device may not be supported run scanimage -L

Doing so returns a message "device not found".

stretchedthin said:

Quote
Try this link to the 'how to's' it just might do the trick...
http://forum.vectorlinux.com/index.php?topic=8497.msg57608#msg57608

I gave that a whirl but it did not work for me.

I had hoped to get the scanner working on this all in one printer with VL because I have been able to do so in some other Linux variants.  Leave it to me to pick a product that is not supported by the manufacturer for use with Linux.   Roll Eyes

Thanks for your help.

Logged

Custom Mini-Itx - VL6.0 Light
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!