Please support VectorLinux!

Author Topic: (Solved!) Grub menu.lst entry for Vector 6.0 KDE 3.5  (Read 1185 times)

Andy Axnot

  • Member
  • *
  • Posts: 2
(Solved!) Grub menu.lst entry for Vector 6.0 KDE 3.5
« on: May 14, 2010, 06:15:13 pm »
Hi!  I saw the announcement for Vector 6.0 KDE 3.5 on Distrowatch and thought I would give it a try.  (I really don't think KDE 4 is yet ready for prime time.  Sooner or later I'll have to give up on KDE 3, but not just now.)

I installed Vector but skipped installing Lilo.  I then added:
Code: [Select]
title Vector 6.0 KDE 3.5 (on /dev/sdb5)
root (hd1,4)
kernel (hd1,4)/boot/vmlinuz root=/dev/sdb5 vga=788 splash=silent ro
initrd (hd1,4)/boot/initrd
boot

to my menu.lst in PCLinuxOS.  It works, but not properly.  Instead of getting a graphical login I get a graphical terminal where I log in as a user and then issue 'startx' to get a full gui going.

To reboot I have to become root by 'su' and then issue 'reboot'.

Any suggestions appreciated!

Andy
« Last Edit: May 15, 2010, 06:11:19 pm by Andy Axnot »

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4072
Re: Grub menu.lst entry for Vector 6.0 KDE 3.5
« Reply #1 on: May 15, 2010, 05:55:04 pm »
As root, in a terminal, run vasm > xwindow > bootset > mark entry for "4 Graphical user interface desktop" > OK .. until you're back to command prompt. Reboot.

Andy Axnot

  • Member
  • *
  • Posts: 2
Re: Grub menu.lst entry for Vector 6.0 KDE 3.5
« Reply #2 on: May 15, 2010, 06:13:20 pm »
As root, in a terminal, run vasm > xwindow > bootset > mark entry for "4 Graphical user interface desktop" > OK .. until you're back to command prompt. Reboot.

Thank you so much!  That did it.  I had tried vasm, but didn't do it right and lost the gui login on reboot.   ::)

Andy