Tried installing on Alpha 4.6 and it failed saying that dependencies were not met:
firefox: Depends: gconf >= 2.31.1-i586-1vl60
Something must have changed after alpha 4.1 - Firefox was built under alpha 3.??. I've got it running under 4.1, and the correct version of gconf is included in 4.1.
You need to check with Robert, I think.