VectorLinux
April 24, 2014, 11:33:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 [2] 3 4 ... 6
  Print  
Author Topic: VectorLinux 7.0 CORE ALPHA 1  (Read 20388 times)
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #15 on: June 07, 2010, 04:42:31 am »

I've tried to install on a couple of machines (P3, P4) but in both cases it says it can't find the install media, which is an IDE CDROM. Any workarounnd? I haven't tried the GUI installer yet.

Try copying the ISO to the top of an existing partition and then booting the CD
Logged

Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #16 on: June 07, 2010, 08:21:07 am »

Try copying the ISO to the top of an existing partition and then booting the CD

Thanks, I'll try that next time. In the end I managed to install using the GUI installer. The only problem I had was when I finished partitioning and exited gparted I got a blank screen (actually there was a kind of ghost desktop there) and I had to reboot to restart the installation.

Andy
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #17 on: June 07, 2010, 01:12:19 pm »

I probably bit off way too much, starting with trying to build VLC. I managed to get a package out of it, which so far will only play audio. There are also no graphics in the UI. I wonder if these errors (when running program) indicate anything amiss in the VL7 base?

Code:
libpng warning: Incompatible libpng version in application and library
libpng warning: Application was compiled with png.h from libpng-1.2.37
libpng warning: Application  is  running with png.c from libpng-1.4.1

Edit: I get the same errors if I run a pre-built Slackware 13 package.
« Last Edit: June 07, 2010, 02:27:43 pm by nightflier » Logged
vector
Administrator
Vectorite
*****
Posts: 479



« Reply #18 on: June 07, 2010, 03:48:56 pm »

Roy,
Thats qt4 giving you that error. It's about the only thing I didn't rebuild. So if you have time try building qt4 from slack-current/13.1 and you should be ok.

Cheers,
Vec
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #19 on: June 07, 2010, 06:24:53 pm »

This alpha is looking pretty solid. I've just build around 40 different packages.  Mostly the newest version of dependencies for what will hopefully be a VL7.0 version of the MMBD.  I've managed to avoid anything requiring qt so far, but that problem has already been identified.  Really everything has been solid, the only problem I had is that the version number in /var/log/packages is still vl6.0

ls /var/log/packages/vlconfig2-6.0-noarch-6vl60

Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #20 on: June 07, 2010, 08:51:26 pm »

Just ran into this problem, havn't look into it much yet but it looks like I've run into a problem with libtool while building fontforge.

Code:
(cd ../.libs && rm -f libfontforge.so.1 && ln -s libfontforge.so.1.0.0 libfontforge.so.1)
(cd ../.libs && rm -f libfontforge.so && ln -s libfontforge.so.1.0.0 libfontforge.so)
creating ../libfontforge.la
/usr/bin/sed: can't read /home/ken/MMBD/Multimedia/deps/fontforge/20081215/tmp/fontforge-20100501/libgunicode.la: No such file or directory
libtool: link: `/home/ken/MMBD/Multimedia/deps/fontforge/20081215/tmp/fontforge-20100501/libgunicode.la' is not a valid libtool archive
make[1]: *** [../libfontforge.la] Error 1
make[1]: Leaving directory `/home/ken/MMBD/Multimedia/deps/fontforge/20081215/tmp/fontforge-20100501/fontforge'
make: *** [fontforge] Error 2
You have mail in /var/mail/root

Also ran into a couple more problems with building gavl this seems to reference both libtool and png...
Code:
/bin/sh ../libtool --tag=CC   --mode=link gcc  -O2 -march=i586 -mtune=i686   -march=pentium-m -mtune=pentium-m -O3 -funroll-all-loops -fomit-frame-pointer -ffast-math -Wall -Wmissing-declarations -Wdeclaration-after-statement -mfpmath=387 -fvisibility=hidden   -o blend_test blend_test.o ../gavl/libgavl.la -lpng -lz -lrt
libtool: link: gcc -O2 -march=i586 -mtune=i686 -march=pentium-m -mtune=pentium-m -O3 -funroll-all-loops -fomit-frame-pointer -ffast-math -Wall -Wmissing-declarations -Wdeclaration-after-statement -mfpmath=387 -fvisibility=hidden -o .libs/blend_test blend_test.o  ../gavl/.libs/libgavl.so -lpng -lz -lrt
blend_test.o: In function `read_png':
blend_test.c:(.text+0x4a8): undefined reference to `png_set_gray_1_2_4_to_8'
collect2: ld returned 1 exit status
make[1]: *** [blend_test] Error 1
make[1]: Leaving directory `/home/ken/MMBD/Multimedia/deps/gavl/1.1.0/tmp/gavl-1.1.2/src'
make: *** [all-recursive] Error 1


enblend also failed to build.  Think this one is strickly caused by the new libpng14.
Code:
png.cxx:371: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:371: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx: In member function 'void vigra::PngDecoderImpl::nextScanline()':
png.cxx:382: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:382: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx: In constructor 'vigra::PngEncoderImpl::PngEncoderImpl(const std::string&)':
png.cxx:548: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:548: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:559: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:559: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx: In member function 'void vigra::PngEncoderImpl::finalize()':
png.cxx:574: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:574: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:582: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:582: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:591: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:591: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:600: warning: deprecated conversion from string constant to 'char*'
png.cxx:605: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:605: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx: In member function 'void vigra::PngEncoderImpl::write()':
png.cxx:637: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:637: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:640: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
png.cxx:640: warning: 'png_struct_def::jmpbuf' is deprecated (declared at /usr/include/png.h:1090)
make[4]: *** [libvigra_impex_a-png.o] Error 1
make[4]: Leaving directory `/home/ken/MMBD/Multimedia/deps/enblend/4.0/tmp/enblend-enfuse-4.0/src/vigra_impex'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/home/ken/MMBD/Multimedia/deps/enblend/4.0/tmp/enblend-enfuse-4.0/src'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/home/ken/MMBD/Multimedia/deps/enblend/4.0/tmp/enblend-enfuse-4.0/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/home/ken/MMBD/Multimedia/deps/enblend/4.0/tmp/enblend-enfuse-4.0'
make: *** [all] Error 2
You have mail in /var/mail/root
vector://home/ken/MMBD/Multimedia/deps/enblend/4.0/src
root:# mv /tmp/boost-1.43.0-i486-1alien.txz ./

I'll look for patches and such tomorrow.
« Last Edit: June 07, 2010, 09:05:45 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #21 on: June 08, 2010, 03:54:01 am »

building qt4 from slack-current/13.1 and you should be ok.

Thanks. New qt4 did solve the libpng problem. Still no video, looks like we're missing some pieces:
Code:
VLC media player 1.0.6 Goldeneye
[0x80d04a8] main interface error: no interface module matched "inhibit,none"
[0x80d04a8] main interface error: no suitable interface module
[0x804caa8] main libvlc error: interface "inhibit,none" initialization failed
[0x80d04a8] main interface error: no interface module matched "screensaver,none"
[0x80d04a8] main interface error: no suitable interface module
[0x804caa8] main libvlc error: interface "screensaver,none" initialization failed
[0x804caa8] main libvlc error: option drawable-xid does not exist
[0xb6a006c0] main interface error: option x11-display does not exist
[0x804caa8] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[0x80cd270] main interface error: option x11-display does not exist

When trying to play video file:
Code:
[0x82a9a30] main demux error: no meta reader module matched "any"
[0xb6c18348] main scale error: no video filter2 module matched "any"
[0x822ee20] main scale error: no video filter2 module matched "any"

Vec, you want the qt4 package and/or script? I modified the script for VL naming and i586 arch.
« Last Edit: June 08, 2010, 04:36:33 am by nightflier » Logged
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #22 on: June 08, 2010, 06:18:02 pm »

After commenting out the line with "xmodmap ~/.Xmodmap" in .bashrc my keyboard behaves as I want it to. I can now navigate in mc using the down arrow and the end key.

So far built vlc, htop, bluefish and samba without errors.
Logged
MikeCindi
Tester
Vectorian
****
Posts: 1071


« Reply #23 on: June 08, 2010, 06:52:20 pm »

Quote
After commenting out the line with "xmodmap ~/.Xmodmap" in .bashrc my keyboard behaves as I want it to. I can now navigate in mc using the down arrow and the end key.
I'll try that as I've had this problem with VL6 SOHO and it drives me nuts!

This hack didn't work for me in SOHO rc2.8.
« Last Edit: June 11, 2010, 02:53:59 pm by MikeCindi » Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
nightflier
Administrator
Vectorian
*****
Posts: 3942



« Reply #24 on: June 09, 2010, 08:39:14 am »

KDE3 Lives!
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #25 on: June 09, 2010, 08:49:20 am »

Nice!!!
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
prince
Vectorite
***
Posts: 182


« Reply #26 on: June 09, 2010, 09:40:55 am »

stretchedthin, since we are testing here, is Btrfs out of the equation?

Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #27 on: June 09, 2010, 10:37:19 am »

stretchedthin, since we are testing here, is Btrfs out of the equation?



Sorry Prince.  Can't speak for everyone, but it is out of reach for me.  I've got my hands full right now. Perhaps one of the others will tackle it.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
bigpaws
Vectorian
****
Posts: 1835


« Reply #28 on: June 09, 2010, 12:01:32 pm »

Prince why not build it yourself, that is the beauty of
linux is you can make it do what you want.

Bigpaws

Logged
MikeCindi
Tester
Vectorian
****
Posts: 1071


« Reply #29 on: June 09, 2010, 05:52:08 pm »

Tried loading VL7 on my laptop and again it dropped out setup when detecting the display (Nvidia GeForce Go 7150M). It would seem xorg doesn't support this still as it was not listed in /var/log/Xorg.0.log. As I mentioned in the VL6 SOHO testing this seems odd as VL6 Standard and Light have no issues. So the xorg update dropped this chipset which also seems odd to me since there are many older chipsets listed than this one. Perhaps it's not a very popular Nvidia offering. I did notice that when I then loaded it in VBox the text installer was available again (only to fail to find the media in the virtual CD device it was reading from).
« Last Edit: June 09, 2010, 05:55:05 pm by MikeCindi » Logged

The plans of the diligent lead to profit...Pro. 21:5
VL64 7.1b3                                     RLU 486143
Pages: 1 [2] 3 4 ... 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!