VectorLinux
October 30, 2014, 03:52:36 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 2 [3] 4 5 6
  Print  
Author Topic: VectorLinux 7.0 CORE ALPHA 1  (Read 23052 times)
kidd
Packager
Vectorian
****
Posts: 682


« Reply #30 on: June 10, 2010, 05:47:07 am »

I see vl7 comes with perl 5.10 .

There has been some bugfix releases and a major new version (5.12), with another bugfix release (5.12.1) . Is it too late to bundle perl 5.12.1 in vl7 ?

Logged

GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #31 on: June 11, 2010, 05:44:25 pm »

I installed my printers today. I couldn't do it through VASM. It said CUPS was not installed or something like that. I did have the CUPS service running. Then I ran Firefox as root and installed the printers through http://localhost:631, No problems with that and the printers are working fine.

Still no way to install LILO to a floppy. I booted into my VL6 SOHO RC2.8 and tried to modify LILO to list VL7, but LILO didn't list VL7 as an option. I noticed that there is no /tamu subdirectory in VL7 nor a vmlinuz link. I boot to VL7 with the installation CD.

I tried sane-find-scanner but it complained about a missing library. I didn't pursue it.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
retired1af
Packager
Vectorian
****
Posts: 1265



« Reply #32 on: June 12, 2010, 07:11:31 am »

Things have finally settled down somewhat regarding the server so I should be able to start really playing with this. I'll report back after I do some updates. Smiley
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #33 on: June 12, 2010, 01:27:38 pm »

Might I suggest you roll out a 64b edition parallel to the 32b... that way they can both grow simultaneously

Thank you!  The only real reason I'm not running Vector Linux nowadays was that I really, truly needed 64-bit and a release never materialized.  I'm using SalixOS, which I like, but I felt a connection to the Vector Linux community and made some friends here.   64-bit would bring me back into the fold, so to speak  Grin
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #34 on: June 12, 2010, 01:30:20 pm »

KDE3 Lives!

Are you using Trinity (KDE 3.5.12) or the last 3.5.10 build?
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
caitlyn
Packager
Vectorian
****
Posts: 2876


WWW
« Reply #35 on: June 12, 2010, 01:53:33 pm »

Can't promise anything, but I'll try to have an updated sbbuilder for v7 during the next week.

Great!  Any chance of getting the source code into the source repositories for VL 6 as well as your build script?
Logged

eMachines EL-1300G desktop, 1.6GHz AMD Athlon 2650e CPU, 4GB RAM, nVidia GeForce 6150 SE video
CentOS 6.5 (will try VL64-7.1 soon)

Toshiba Satellite A135-S4727,  Intel Pentium T2080 / 1.73 GHz, 2GB RAM, Intel GMA 950

HP Mini 110 netbook, 1.6GHz Intel Atom CPU, 2GB RAM, Intel 950 video, VL 7.1
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #36 on: June 13, 2010, 12:50:09 am »

Couple things came up while packaging on the new alpha.
I finished packaging Lives and noticed vl7.0 is using sox version 14.2.0, this version dates back to 2008.  14.3.1 is the newest sox available, would it be possible to go to that.  Also there is something called sox_fmt_all, that Lives asks for when sox is chosen for sound.  I can't find a source to build that myself or documentation stating whether it is a configure option at build time.  Or perhaps it is only an option on the new sox versions.  If posible perhaps this mysterious 'sox_fmt_all' could also be worked in.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
prince
Vectorite
***
Posts: 183


« Reply #37 on: June 13, 2010, 09:27:23 am »

Yes, I agree with Caitlyn, I'm rooting for 64!
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #38 on: June 13, 2010, 10:35:12 am »

Are you using Trinity (KDE 3.5.12) or the last 3.5.10 build?

Right now I'm just experimenting with pre-built Slack 13 (3.5.10) packages. Trinity looks interesting, I will definitely do some research there.
Logged
kidd
Packager
Vectorian
****
Posts: 682


« Reply #39 on: June 14, 2010, 11:05:56 pm »

Can't promise anything, but I'll try to have an updated sbbuilder for v7 during the next week.

Great!  Any chance of getting the source code into the source repositories for VL 6 as well as your build script?

Being a perl script, source code would be exactly the same as binary package.  I think it's already packaged as a noarch package.
Logged

vector
Administrator
Vectorite
*****
Posts: 479



« Reply #40 on: June 14, 2010, 11:06:12 pm »

Quote
Is it too late to bundle perl 5.12.1 in vl7 ?
already done and tested need to remind me the extra modules for sbbuilder please.
Quote
14.3.1 is the newest sox available, would it be possible to go to that.  
Yep did  that too seems sox picks up a lot of extras on the system now so your request should work.
Just a note as a test I built most all of gnome just to see how vl7 held up with the exception of one package (gtkspell) everything built without issue. So I think its solid and good starting point !!!!

Cheers,
Vec
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #41 on: June 15, 2010, 09:48:40 am »

Quote
Just a note as a test I built most all of gnome just to see how vl7 held up with the exception of one package (gtkspell) everything built without issue. So I think its solid and good starting point !!!!

Cheers,
Vec

Same experience here.  I've been building the dependencies for the multimedia bonus disk. The following have build successfully.
Code:
./AMB-plugins/0.6.1/AMB-plugins-0.6.1-i586-1vl70.txz
./FIL-plugins/0.3.0/FIL-plugins-0.3.0-i586-1vl70.txz
./MCP-plugins/0.4.0/MCP-plugins-0.4.0-i586-1vl70.txz
./OpenJPEG/v1.3/OpenJPEG-v1.3-i586-1vl70.txz
./REV-plugins/0.3.1/REV-plugins-0.3.1-i586-1vl70.txz
./VCO-plugins/0.3.0/VCO-plugins-0.3.0-i586-1vl70.txz
./XML-Twig/3.35/XML-Twig-3.35-i586-1vl70.txz
./aften/0.0.8/aften-0.0.8-i586-1vl70.txz
./aubio/0.3.2/aubio-0.3.2-i586-1vl70.txz
./aucdtect/0.8.2/aucdtect-0.8.2-i586-1vl70.txz
./autopano-sift/2.4/autopano-sift-2.4-i586-1vl70.txz
./autotrace/0.31.1/autotrace-0.31.1-i586-1vl70.txz
./babl/0.1.2/babl-0.1.2-i586-1vl70.txz
./blop/0.2.8/blop-0.2.8-i586-1vl70.txz
./boost/1.43.0/boost-1.43.0-i586-1vl70.txz
./cairo-perl/1.061/cairo-perl-1.061-i586-1vl70.txz
./cairo/1.8.10/cairo-1.8.10-i586-1vl70.txz
./cairomm/1.8.4/cairomm-1.8.4-i586-1vl70.txz
./caps-plugins/0.4.4/caps-plugins-0.4.4-i586-1vl70.txz
./cdcd/0.6.6/cdcd-0.6.6-i586-1vl70.txz
./csound/5.12.1/csound-5.12.1-i586-1vl70.txz
./dssi/1.0.0/dssi-1.0.0-i586-1vl70.txz
./dvd-slideshow/0.8.2-2/dvd-slideshow-0.8.2_2-i586-1vl70.txz
./dvdauthor/0.6.18/dvdauthor-0.6.18-i586-1vl70.txz
./dvgrab/3.5/dvgrab-3.5-i586-1vl70.txz
./enblend/4.0/enblend-4.0-i586-1vl70.txz
./exiv2/0.20/exiv2-0.20-i586-1vl70.txz
./extutils-depends/0.302/extutils-depends-0.302-i586-1vl70.txz
./extutils-pkgconfig/1.12/extutils-pkgconfig-1.12-i586-1vl70.txz
./ffmpeg_ken/r23514/ffmpeg-r23514-i586-1vl70.txz
./fftw/3.2.2/fftw-3.2.2-i586-1vl70.txz
./fltk/1.3.x-r7627/fltk-1.3.x-r7627-i586-1vl70.txz
./fltk2/2.0.x-r7513/fltk2-2.0.6403-i586-1vl70.txz
./fluidsynth-dssi/0.9.1/fluidsynth-dssi-1.0.0-i586-1vl70.txz
./fluidsynth/1.1.1/fluidsynth-1.1.1-i586-1vl70.txz
./freeglut/2.4.0/freeglut-2.6.0-i586-1vl70.txz
./frei0r/20100124/frei0r-20100124-i586-1vl70.txz
./gavl/1.1.2/gavl-1.1.2-i586-1vl70.txz
./gc/7.1/gc-7.1-i586-1vl70.txz
./glib-perl/1.162/glib-perl-1.223-i586-1vl70.txz
./glibmm/2.18.1/glibmm-2.22.2-i586-1vl70.txz
./gss/1.0.1/gss-1.0.1-i586-1vl70.txz
./gtk-sharp/2.12.9/gtk-sharp-2.12.9-i586-1vl70.txz
./gtk-sharp1/1.0.10/gtk-sharp1-1.0.10-i586-1vl70.txz
./gtk2-perl/1.222/gtk2-perl-1.222-i586-1vl70.txz
./gtkmm/2.18.0/gtkmm-2.18.0-i586-1vl70.txz
./gtksourceview/2.11.2/gtksourceview-2.11.2-i586-1vl70.txz
./ilmbase/1.0.1/ilmbase-1.0.1-i586-1vl70.txz
./imaging/1.1.7/Imaging-1.1.7-i586-1vl70.txz
./jack/0.118.0/jack-0.118.0-i586-1vl70.txz
./jdelay/noversion/jack_delay-noversion-i586-1vl70.txz
./ladspa/1.13/ladspa-1.13-i586-1vl70.txz
./libatomic_ops/1.2/libatomic_ops-1.2-i586-1vl70.txz
./libcdaudio/0.99.12p2/libcdaudio-0.99.12p2-i586-1vl70.txz
./libgig/3.3.0/libgig-3.3.0-i586-1vl70.txz
./libgnomecanvas/2.26.0/libgnomecanvas-2.26.0-i586-1vl70.txz
./libgnomecanvasmm/2.26.0/libgnomecanvasmm-2.26.0-i586-1vl70.txz
./libgsasl/1.4.4/libgsasl-1.4.4-i586-1vl70.txz
./libiec61883/1.2.0/libiec61883-1.2.0-i586-1vl70.txz
./liblo/0.26/liblo-0.26-i586-1vl70.txz
./liblrdf/0.4.0/liblrdf-0.4.0-i586-1vl70.txz
./liblscp/0.5.6/liblscp-0.5.6-i586-1vl70.txz
./libpano13/2.9.14/libpano13-2.9.14-i586-1vl70.txz
./libquicktime/1.1.5/libquicktime-1.1.5-i586-1vl70.txz
./libsigc++/2.2.8/libsigc++-2.2.8-i586-1vl70.txz
./libsndfile/1.0.21/libsndfile-1.0.21-i586-1vl70.txz
./libxmi/1.2/libxmi-1.2-i586-1vl70.txz
./linuxsampler/1.0.0/linuxsampler-1.0.0-i586-1vl70.txz
./lsdvd/0.16/lsdvd-0.16-i586-1vl70.txz
./mftrace/1.2.16/mftrace-1.2.16-i586-1vl70.txz
./mjpegtools/1.9.0/mjpegtools-1.9.0-i586-1vl70.txz
./mlt/0.5.4/mlt-0.5.4-i586-1vl70.txz
./mono/2.6.4/mono-2.6.4-i586-1vl70.txz
./mutagen/1.13/mutagen-1.19-i586-1vl70.txz
./omins/0.2.0/omins-0.2.0-i586-1vl70.txz
./pango-perl/1.221/pango-perl-1.221-i586-1vl70.txz
./pangomm/2.25.1.3/pangomm-2.25.1.3-i586-1vl70.txz
./pigment/0.3.17/pigment-0.3.17-i586-1vl70.txz
./pixman/0.18.2/pixman-0.18.2-i586-1vl70.txz
./portaudio/20071002/portaudio-20071002-i586-1vl70.txz
./potrace/1.8/potrace-1.8-i586-1vl70.txz
./pulseaudio/0.9.13/pulseaudio-0.9.21-i586-1vl70.txz
./python-setuptools/0.6c11/python-setuptools-0.6c11-i586-1vl70.txz
./qt4/4.6.2/qt-4.6.2_2d3d3e5-i586-1VL70.txz
./raptor/1.4.21/raptor-1.4.21-i586-1vl70.txz
./scons/1.1.0/scons-1.3.0-i586-1vl70.txz
./scrollkeeper/0.3.14/scrollkeeper-0.3.14-i586-1vl70.txz
./shishi/0.0.37/shishi-0.0.43-i586-1vl70.txz
./sip/4.7.9/sip-4.10.2-i586-1vl70.txz
./soundtouch/1.3.1/soundtouch-1.5.0-i586-1vl70.txz
./speex/1.2beta3/speex-1.2beta3-i586-1vl70.txz
./swh-plugins/0.4.15/swh-plugins-0.4.15-i586-1vl70.txz
./swig/2.0.0/swig-2.0.0-i586-1vl70.txz
./ttf2pt1/3.4.4/ttf2pt1-3.4.4-i586-1vl70.txz
./wxGTK/2.8.9/wxGTK-2.8.11-i586-1vl70.txz
./wxPython/2.8.7.1/wxPython-2.8.11.0--.txz
./wxsvg/1.0.3/wxsvg-1.0.3-i586-1vl70.txz
./wxwidgets/2.8.11/wxWidgets-2.8.11-i586-1vl70.txz
./yasm/1.0.1/yasm-1.0.1-i586-1.txz
./denemo/0.7.6/denemo-0.8.14-i586-1vl70.txz
./dia/0.96.1/dia-0.97-i586-1vl70.txz
./lives/0.9.9.5/lives-1.3.3-i586-3vl70.txz
./lmms/0.4.6/lmms-0.4.6-i586-1vl70.txz
./mixxx/1.7.2/mixxx-1.7.2-i586-1vl70.txz
The most trouble I've had is with libpng patches, which I'm now getting pretty good at.  However, the following have are still giving me trouble and will not build. I'm assuming they related to the new libpng or libjpeg or maybe even libtool. I'll have to investigate a little more.
Code:
bonk-0.6/  package-bonk

glew-1.5.4/  package-glew/

lash-0.5.4/  package-lash/

[s]libgdiplus-2.4.2/  package-libgdiplus/[/s]

[s]lilypond-2.12.3/  package-lilypond/
[/s]
openexr-1.6.1/  package-openexr/

package-povray/  povray-3.6.1/

[s]package-recordmydesktop/  recordmydesktop-0.3.8.1/
[/s]
package-tse3/  tse3-0.3.1/

package-yafray/  yafray/
I may edit from the above list as I find out what the fix is.
« Last Edit: June 16, 2010, 10:50:15 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
Dweeberkitty
Packager
Vectorian
****
Posts: 836



WWW
« Reply #42 on: June 15, 2010, 02:07:08 pm »

stretchedthin,

FYI, the lilypond package was probably one of the hardest packages I ever had to build. It may or may not be the libpng or libjpeg. Just be aware that it gave me a LOT of trouble in the past.
Logged

Registered Linux User #443399
Desktop: Intel Pentium D 3.33Ghz, 320GB hard drive, 2 gigs DDR2 533mhz RAM, NVIDIA Geforce 7800 GS, X2GEN 22" widescreen monitor;
Laptop: Dell Mini 9, Intel Atom 1.6Ghz, 1GB ram
Multimedia Bonus Disc website: http://www.vectorlinuxsolutions.com/
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #43 on: June 15, 2010, 11:39:31 pm »

Found this when researching why one of the packages I'm working on ends with the following error.
Code:
checking for cairo's Microsoft Windows font backend...
checking whether cairo's Microsoft Windows font backend could be enabled... no (requires a Win32 platform)
checking whether we are using the GNU C++ compiler... (cached) yes
checking whether g++ accepts -g... (cached) yes
checking dependency style of g++... (cached) gcc3
checking for cairo's PNG backend...
configure: WARNING: Could not find libpng in the pkg-config search path
checking whether cairo's PNG backend could be enabled... no
configure: error: requested PNG backend could not be enabled
configure: error: ./configure failed for cairo
You have mail in /var/mail/root

Quote
Dear Cairo developers,

the configure.ac of cairo seems to contain a list of libpng
package names: (line 164)

    for l in libpng12 libpng13 libpng10 ; do

This list won't support the new libpng 1.4.x versions, although
cairo seems to work flawlessly with them. So I propose to either
add "libpng14" to the list:

    for l in libpng14 libpng12 libpng13 libpng10 ; do

or to simply add "libpng" to the list which should always point
to the most current libpng version:

    for l in libpng libpng12 libpng13 libpng10 ; do

From the looks of it a patch may be necessary for Cairo to work correctly with the new libpng
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
kidd
Packager
Vectorian
****
Posts: 682


« Reply #44 on: June 15, 2010, 11:51:30 pm »

Template Toolkit is the only non-standard module.

you can install it with

Code:
cpan Template

or download and install from:
http://search.cpan.org/~abw/Template-Toolkit-2.22/lib/Template.pm
Code:
perl Makefile.PL
make
make install

the make install route won't install deps (if any)
Logged

Pages: 1 2 [3] 4 5 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!