VectorLinux
October 24, 2014, 03:06:38 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: 1 ... 3 4 [5] 6
  Print  
Author Topic: VectorLinux 7.0 CORE ALPHA 1  (Read 22821 times)
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #60 on: June 28, 2010, 03:19:46 am »

The version of VLC I was working with is the monster static one with all dependencies, including Slack patches, built in (except qt4 in this case).

The script progressed through the whole dep list without throwing a fit and the logs show that all this did build:
# Dependent package versions (list from slackbuild).
Code:
A52=0.7.4
AMR=0.1.2
ASS=0.9.9
AVC1394=0.5.3
CDDB=1.3.2
CDIO=0.82
DAAP=0.4.0
DC1394=2.1.2
DCA=0.0.5
DV=1.0.0
DVBPSI=0.1.7
DVDNAV=4.1.3
DVDREAD=4.1.3
DVDCSS=1.2.10
EBML=1.0.0
FAAC=1.28
FAAD2=2.7
FFMPEG=0.6
FLUID=1.1.1
GGI=2.2.2
GII=1.0.2
GOOM=2k4-0
KATE=0.3.7
LAME=3.98.4
LIBVA="0.31.0-1+sds13"
LIVE=latest
LUA=5.1.4
MATROSKA=1.0.0
MPCDEC=1.2.6
MPEG2DEC=0.5.1
ORC=0.4.5
PROJECTM=2.0.1
QT4=4.6.0
RAW1394=2.0.5
SCHROEDINGER=1.0.9
SHOUT=2.2.2
SPEEX=1.2rc1
SWSCALE=""       # Set SWSCALE="" to checkout a version of ffmpeg's swscale that matches the date of the FFMPEG snapshot.
THEORA=1.1.1
TIGER=0.3.3
TWOLAME=0.3.12
UPNP=1.6.6
V4L=0.8.0
VCD=0.7.23
VPX=20100617
X264_SAFE=20080301-2245 # In later versions nasm complains about 'function hidden'
X264=20100616-2245      # Needs yasm installed
XUL=1.9.2

Here is the tail of the build log:
Code:
  CCLD   libvod_rtsp_plugin.la
  CCLD   libfreetype_plugin.la
/usr/lib/gcc/i586-vector-linux/4.3.3/../../../../i586-vector-linux/bin/ld: cannot find -lpng12
collect2: ld returned 1 exit status
make[5]: *** [libsvg_plugin.la] Error 1
make[5]: *** Waiting for unfinished jobs....
make[5]: Leaving directory `/temp/tmp-vlc/vlc-1.1.0/modules/misc'
make[4]: *** [all-recursive] Error 1
make[4]: Leaving directory `/temp/tmp-vlc/vlc-1.1.0/modules/misc'
make[3]: *** [all] Error 2
make[3]: Leaving directory `/temp/tmp-vlc/vlc-1.1.0/modules/misc'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/temp/tmp-vlc/vlc-1.1.0/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/temp/tmp-vlc/vlc-1.1.0'
make: *** [all] Error 2

Looks like it was doing something with freetype at the time?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #61 on: June 28, 2010, 04:39:23 am »

libpng.

I was playing around with slack13.1 and found out they have a libpng-compat package that takes care of this.
You still need to specify a path at build time for it to find and use the right library.
Logged

toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #62 on: June 28, 2010, 06:54:57 pm »

Finally got a bit of time and thought I'd have a look at the alpha.

Small problem though. If I attempt to use the GUI installer it fails with a fatal error. Using the text mode installer can't find the CD.

Another problem - the fatal error with the GUI installer is down to kernel module loading. After getting to a command prompt, I had a look at /llib/modules. Under that, there are two directories for kenrel modules - 2.6.31.11 and 2.6.31.6. But 'uname -r' gives me 2.6.32.2.

I give up. How do I get the thing to install  Huh

Paul.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #63 on: June 29, 2010, 04:45:09 am »

heh... sounds like one messed up ISO
Logged

toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #64 on: June 29, 2010, 06:57:43 am »

heh... sounds like one messed up ISO

Smiley That was my first assumption. However, md5sum matches, both on the downloaded iso and on the cd I burnt.

Very strange. I should be able to investigate a bit more later tonight, I hope. Annoying through - I wanted to install it and see how I went building a few packages against it.

Paul.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #65 on: July 02, 2010, 08:05:50 pm »

Quote
/usr/lib/gcc/i586-vector-linux/4.3.3/../../../../i586-vector-linux/bin/ld: cannot find -lpng12
This is coming from a dep lib for the program which I may not have caught libmng comes to mind. Anyway ldd your executable look at the libs it uses and check /var/adm/packages see if the dep has a i486 extension that is somehow related to graphics/gui then you will prolly have to rebuild that against the libpng14. Its kind of a hunt and peck but if you guys could help me this would be appreciated.

Thanks,
Vec

I think I found one.  I could not build gegl 0.1.3, was getting one of those...can't find libpng12 errors.  Luckily gegl has a short list of dependencies and the one that caught my eye was librsvg.  I rebuilt against libpng14 and installed librsvg-2.31.0, installed it and re-ran my gegl build and voila, no more errors.  Looking at the errors that nightflier got I think it may be the solution for his vlc build as well.
Ken
P.S. Could you post the slackbuild you use for libmng.  I'll give that one a go as well and see if that helps with some of the others I've had trouble with?
« Last Edit: July 02, 2010, 10:20:19 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
toothandnail
Tester
Vectorian
****
Posts: 2527


« Reply #66 on: July 03, 2010, 06:01:07 am »

Sad I can't install this at all. I've checked the md5sum of the downloaded iso (its correct), reburnt the CD at the slowest speed my drive will do, then checked the md5sum on the burnt CD (also fine).

I get a boot prompt, press enter and the CD boots. It gets to the resolution prompt, I select 12800x800 (T61 14.1 widescreen) and it goes away to test the X setup. After a little while, it comes back with this message, repeated twice:

Code:
Xorg sucessfully configured
Modprobe: FATAL could not load /lib/modules/2.6.32.2/modules.dep no such file or directory

At which point I can log in as root, but that is it - no chance to install, and no chance to get GUI installer to come up.

Checking the system, if I look at /lib/modules/, I've got a 2.6.31.11 and a 2.6.30.6 directory, but certainly not a 2.6.32.2 directory.

The problem looks like its mainly video - the T61 has an Intel GM965-based card. Running lspci on the alpha the card is not correctly identified:

Code:
Vga Compatible controller: Intel Croporation Device 2o02

And the failure does not occur until the system attempts to start X.

I'd really like to be able to install this, but I'm now pretty sure there is nothing wrong with the CD I'm using, and I'm getting nowhere at all....

Paul.
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #67 on: July 03, 2010, 10:21:11 am »

@toothandnail, I don't have a solution for you but can confirm your experience.  I had the same error messages on two out of the three machines I tried this on.  I don't think you have a problem with your disk at all. If you try the same disk installing to a Virtualbox virtual machine you might be surprised to see it actually works.  For what it is worth the two machines that gave me the error had intel graphics, the one that worked had ati (of all things).
Ken
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
vector
Administrator
Vectorite
*****
Posts: 479



« Reply #68 on: July 04, 2010, 07:26:40 pm »

Quote
'd really like to be able to install this, but I'm now pretty sure there is nothing wrong with the CD I'm using, and I'm getting nowhere at all....

Paul.

Paul and Ken and  anyone with intel graphics give this version of  VL7-CORE a try:
http://vectorlinux.osuosl.org/veclinux-7.0/iso-test/VL7.0-CORE-ALPHA-1.2.iso
http://vectorlinux.osuosl.org/veclinux-7.0/iso-test/ALPHA-1.2.md5sum

I discovered there were some missing kernel module bits in the installer after your posts revealed the problem ...........thanks for the detective work!!!!........... Grin
Nothing else much has changed from ALPHA1 so if that installed ok for you then anyone else can leave this iso alone. Also there is a delta in the veclinux-7.0/iso-test folder if you want to save some download time.
Let me know how it goes............and happy 4th of July to all you folks from the USA!!

Cheers,
Vec
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #69 on: July 04, 2010, 11:32:22 pm »

Tried the new alpha install on the two intel machines that failed on the previous.  Same bad news I'm afraid,
still getting the same error and failure to launch x that Paul described.
Quote
Xorg sucessfully configured
Modprobe: FATAL could not load /lib/modules/2.6.32.2/modules.dep no such file or directory
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #70 on: July 05, 2010, 06:04:46 am »

So far this is what I've found that I believe needs to be rebuilt against libpng...librsvg, poppler, and possibly lcms.  Side note all three of them have newer versions available and in the case of lcms a major new version.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
vector
Administrator
Vectorite
*****
Posts: 479



« Reply #71 on: July 05, 2010, 10:52:40 am »

Quote
Modprobe: FATAL could not load /lib/modules/2.6.32.2/modules.dep no such file or directory
When you get dumped to the cli try doing depmod -a then try startx again. let me know what it tells you.

Thanks,
Vec
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #72 on: July 05, 2010, 02:19:46 pm »

Quote
Modprobe: FATAL could not load /lib/modules/2.6.32.2/modules.dep no such file or directory
When you get dumped to the cli try doing depmod -a then try startx again. let me know what it tells you.

Thanks,
Vec
Tried as you suggested when kicked, signed in as root and ran depmod -a.  I just end up getting the same warning...
depmod # depmod -a
WARNING: Couldn't open directory /lib/modules/2.6.32.2/: No such file or directory
FATAL: Could not open /lib/modules/2.6.32.2/modules.dep.temp for writing: No such file or directory.


So I use ls to look in /lib/modules/  it contains two folders 2.6.31.11 and 2.6.31.6.  There is no reference to a 2.6.32.2.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
prince
Vectorite
***
Posts: 183


« Reply #73 on: July 05, 2010, 03:37:32 pm »

Excuse me, gentlemen.

May we restart with Kernel # 2.6.33, please.  Thanks.
Logged
vector
Administrator
Vectorite
*****
Posts: 479



« Reply #74 on: July 05, 2010, 05:20:55 pm »

Quote
WARNING: Couldn't open directory /lib/modules/2.6.32.2/: No such file or directory
FATAL: Could not open /lib/modules/2.6.32.2/modules.dep.temp for writing: No such file or directory.


So I use ls to look in /lib/modules/  it contains two folders 2.6.31.11 and 2.6.31.6.  There is no reference to a 2.6.32.2.

Oops!! my bad looks like one of my build scripts replaced my update with original. So could we please try again?
new iso and delta are up the exact same links as previous same versioning I just replaced them.

Thanks,
Vec
Logged
Pages: 1 ... 3 4 [5] 6
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!