VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: How-to startup programs automatically  (Read 2784 times)

brampieke

  • Member
  • *
  • Posts: 34
How-to startup programs automatically
« on: June 06, 2010, 02:15:11 am »

Hello,

I've installed gkrellm,obmixer and wbar. I would like to let this start automatically.
I'm using VL 6.0 Light, so I opened ~/.icewm/startup.

I gave in this code :

obmixer &
gkrellm &
wbar config $HOME/.wbar -above-desk -pos top &


I also would like to put gkrellm on the right-top...

Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: How-to startup programs automatically
« Reply #1 on: June 06, 2010, 05:30:05 am »

For gkrellm, right-click at the top of it and select Configuration. Among all the options you should find one for "Remember position..".

For these programs to settle in properly, the Icewm panel and desktop should be stabilized. It may be necessary to introduce a delay by adding a line above the commands:
Code: [Select]
sleep 3
Three seconds is a good starting point. Experiment with different numbers until you find the optimal setting for your computer.
Logged

brampieke

  • Member
  • *
  • Posts: 34
Re: How-to startup programs automatically
« Reply #2 on: June 06, 2010, 06:33:58 am »

Do you mean above all my commands. Separatly or just once?
I tried it separatly but this didn't worked.

Is it normal that I only can show wbar when I go on wbarconf and then do refresh?
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: How-to startup programs automatically
« Reply #3 on: June 06, 2010, 06:59:45 am »

The command goes on a line by itself, right before your commands, like this:
Code: [Select]
sleep 3
obmixer &
gkrellm &
wbar config $HOME/.wbar -above-desk -pos top &

Your wbar should just load without any more intervention. See if the delay helps.
Logged

brampieke

  • Member
  • *
  • Posts: 34
Re: How-to startup programs automatically
« Reply #4 on: June 06, 2010, 09:16:56 am »

It doesn't work...

It this the right place?
~/.icewm/startup
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: How-to startup programs automatically
« Reply #5 on: June 06, 2010, 10:48:53 am »

Assuming you are running IceWM, not the alternative JWM or another window manager,
~/.icewm/startup is the correct file. Make sure it is executable.

When you say it doesn't work, what are you referring to? Is "it" obmixer plus gkrellm plus wbar, only one of them, or something else?
Logged

brampieke

  • Member
  • *
  • Posts: 34
Re: How-to startup programs automatically
« Reply #6 on: June 07, 2010, 01:31:22 am »

yes I work with IceWM.

The things that doesn't work are wbar, obmixer and gkrellm (the things that I added).
The things that were all ready in there like.. the starting tune (sound) does work.. So that's what's weird...

here's my code
Code: [Select]
#!/bin/sh


# use pcmanfm to show desktop background and icons
pcmanfm &
# disable touchpad while typing, half second delay
#syndaemon -i .5 -d &
# enable two finger vertical scrolling
#synclient VertTwoFingerScroll=1 &
# play startup sound
play .icewm/sounds/startup.wav &
sleep 3
wbar -config $HOME/.wbar -above-desk -pos top &
obmixer &
gkrellm &

 
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4131
Re: How-to startup programs automatically
« Reply #7 on: June 07, 2010, 05:11:50 am »

As your regular user, make a copy of your ~/.icewm/startup file, let's call it ~/testscript. Open it in an editor and comment out (place a # at the beginning of) the line "pcmanfm &". This will prevent that command from running.
Open a terminal. Use command:
Code: [Select]
sh testscript
You should hear the startup sound. Watch the terminal window for error messages.
Also look for the terminal to "return to ready", that it doesn't hang on any of the commands.
Logged

brampieke

  • Member
  • *
  • Posts: 34
Re: How-to startup programs automatically
« Reply #8 on: June 07, 2010, 05:41:39 am »

I know that's a stupid question, but where can I find the file? Because I was searching with nautilus and I didn't find it...
Logged

bigpaws

  • Vectorian
  • ****
  • Posts: 1871
Re: How-to startup programs automatically
« Reply #9 on: June 07, 2010, 10:09:42 am »

Nautilius? You have gnome installed?

The full path to the file is /home/<your user name here, no brackets/.icewm

The . is for hidden directories.

Bigpaws
Logged

roarde

  • Vectorian
  • ****
  • Posts: 612
  • move the needle
Re: How-to startup programs automatically
« Reply #10 on: June 07, 2010, 10:28:19 am »

Shot in the dark:
At the login screen, click the "session" button  and choose icewm.

I saw the note saying do not do the following: but did it anyway:
Do not:, in gslapt, do update, mark all upgrades, install.

My symptoms were similar to yours, and included a switch to Nautilus. Selecting icewm session solved the problem, but didn't remove all those extra files. From then on, icewm will start because it's now your default session.

There may be other reasons this would happen. If you prefer Nautilus and installed it intentionally, that may have done it. Still select icewm session, then start Nautilus in ~/.icewm/startup. No idea what incompatibilites are there, but they can be solved. If you're going to use Nautilus, you'll need to comment out or remove pcmanfm in startup, like Nightflier suggested with your testscript.

The testscript idea's a really good one. If it runs as expected with no errors, chances are you're not using icewm now. If it has errors, post them if you need help.
Logged
Robert
VL 7.1 Light