VectorLinux
April 22, 2014, 10:53:01 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Wireless USB Adapter (DLINK WUA 2340)  (Read 814 times)
ertw1
Member
*
Posts: 5


« on: June 06, 2010, 01:54:47 pm »

Hello,

I am trying to get my wireless USB Adapter (DLINK WUA 2340) to work.  I tried using ndiswrapper according to the instructions at this link:  http://www.linuxquestions.org/questions/linux-hardware-18/d-link-wua-2340-installation-problem-789851/

As root I managed to install the driver, however when I go to activate the device by entering the command
Code:
modprobe ndiswrapper
VL just freezes. 

Any help would be really appreciated!  Smiley
Logged
bigpaws
Vectorian
****
Posts: 1833


« Reply #1 on: June 06, 2010, 04:02:22 pm »

First which Vector version are you using?

Bigpaws
Logged
ertw1
Member
*
Posts: 5


« Reply #2 on: June 08, 2010, 11:47:55 am »

First which Vector version are you using?

Bigpaws

I am using VL 6.0
Logged
ertw1
Member
*
Posts: 5


« Reply #3 on: June 08, 2010, 12:45:51 pm »

I managed to somewhat get it to work...but still problematic:

1) removed ndiswrapper and recompiled it from source.
2) physically disconnected the wireless usb adapter from my computer.
3) installed the wifi drivers using ndiswrapper (successfully)
4) removed the ndiswrapper module from the kernel
Code:
rmmod -f ndiswrapper
5) added the ndiswrapper module to the kernel
Code:
modprobe ndiswrapper
6) physically inserted the wireless usb adapter to my computer
7) opened the wicd manager --> Preferences --> General Settings --> WPA Supplicant Driver --> wext

This way it works, however it will freeze if I plug in the adapter before entering the command
Code:
modprobe ndiswrapper
.

This means that I can't have ndiswrapper run on startup while my wireless adapter is plugged in or else my computer will freeze on bootup.
Logged
bigpaws
Vectorian
****
Posts: 1833


« Reply #4 on: June 08, 2010, 03:12:30 pm »

Test this.

Add this to /etc/rc.d/rc.local

/sbin/modprobe ndiswrapper

Leave the USB device connected and then reboot,
report the results here.

Bigpaws
Logged
ertw1
Member
*
Posts: 5


« Reply #5 on: June 11, 2010, 01:48:44 pm »

Test this.

Add this to /etc/rc.d/rc.local

/sbin/modprobe ndiswrapper

Leave the USB device connected and then reboot,
report the results here.

Bigpaws

I'm sorry for the late reply.  Thanks for the help.

I added this line to the file you specified.  I can get to the VL load screen but it hangs before it can get to the Multi-User GUI login screen.  Is there some way that I could "unmount" or digitally disconnect the USB device and reconnect it so I don't have to do this physically?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!