VectorLinux
October 25, 2014, 10:40:03 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: alsamixer  (Read 1091 times)
666lawyer
Member
*
Posts: 60


« on: June 10, 2010, 10:11:11 am »

Hola,

Intento ejecutar alsamixer desde una terminal y dice :

function snd_ctl_open failed for default : No such file or directory

Alguna idea? Huh. Gracias
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #1 on: June 10, 2010, 12:50:03 pm »

No tienes drivers para tu tarjeta de audio.

Necesitas asegurarte de que tengas el codigo fuente del nucleo, y construir el paquete alsa-driver. luego lo instalas.
Logged

666lawyer
Member
*
Posts: 60


« Reply #2 on: June 11, 2010, 04:49:11 am »

Hola,

Gracias por responder.  Pero me resulta extraño lo que me decis.  Si entro por el vasm en configurar hadware, sonido me reconoce las tarjetas!
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #3 on: June 11, 2010, 06:31:33 am »

Talvez tengas razon, pero siempre que yo he visto eso, esta vinculado con el alsa-driver. A proposito, hiciste una actualizacion? o nunca ha funcionado tu sonido?
Logged

666lawyer
Member
*
Posts: 60


« Reply #4 on: June 11, 2010, 07:40:09 am »

El sonido funciona, lo que quiero es poder ponerlo en mute porque tiene un  modem y a veces la conexión no es muy buena y para que trasmitiera en cogio morse y se vuelve bastante molesto.
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3185



« Reply #5 on: June 11, 2010, 08:55:51 am »

Oh Sad
No se que decirte entonces
Logged

newt
Vectorian
****
Posts: 1132



« Reply #6 on: June 11, 2010, 10:37:39 am »

666lawyer would like to mute the dial-up modem noise that comes through the sound card because it can become annoying when having to constantly reconnect due to dropped internet connections, however when running 'alsamixer' from the terminal he receives the error: "function snd_ctl_open failed for default : No such file or directory".  His sound card is functioning fine but he cannot access 'alsamixer' from terminal. Is that close to correct?

Is there possibly a physical cable that connects the modem to audio card inside the system that can be disconnected? Or if everything is integrated, maybe there is an option in the BIOS to disable the modem audio?
Logged
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #7 on: June 11, 2010, 03:37:39 pm »

This can usually be done in a modem chat script, but exactly what command to use varies modem-by-modem. Also, it's been so long I can't remember more about how it's done. Hope this helps anyway.

Come to think of it, there's bound to be a ms-windows or DOS guide for silencing this modem. Putting roughly the same commands in the chat script should work. Won't solve the problem with alsamixer, tho.

Which modem?
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
roarde
Vectorian
****
Posts: 532


move the needle


« Reply #8 on: June 11, 2010, 07:34:28 pm »

Most modems recognize most of the AT command set.

http://opensource.become.com/linuxgazette/issue42/lg_tips42.html#primes    See "Shutting Up Yer Modem"

It's ATM0 .

As for alsamixer, see if this helps:

As root, run

alsaconf
« Last Edit: June 11, 2010, 07:56:23 pm by sixforty » Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!