VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Windows can't boot in dual-boot  (Read 1187 times)

brampieke

  • Member
  • *
  • Posts: 34
Windows can't boot in dual-boot
« on: June 12, 2010, 03:10:34 am »

Hello,

The weird thing is that it had worked. Now, suddenly, Windows 7 doesn't want to boot anymore.
Vector still works. I don't know what I've installed (MBR I suppose)
In other distro I could solve this by adding a line in /boot/grub/menu.lst, but now there isn't one.
How can I fix this and is there a way to see, with what I'm working? (grub, grub2, mbr, lilo)

Logged

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1331
Re: Windows can't boot in dual-boot
« Reply #1 on: June 12, 2010, 08:06:54 am »

What is the error message you receive? If you're running GRUB2, your entries are in /boot/grub/grub.cfg.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

brampieke

  • Member
  • *
  • Posts: 34
Re: Windows can't boot in dual-boot
« Reply #2 on: June 13, 2010, 01:05:22 am »

It says : BootMGR is missing
press CTRL + ALT + DELL to restart

Do I have to install something? Or is there a textfile that I can change, but this isn't the problem I think?
« Last Edit: June 14, 2010, 07:39:13 am by brampieke »
Logged

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
Re: Windows can't boot in dual-boot
« Reply #3 on: June 14, 2010, 06:14:32 pm »

You are probably using lilo. Check and see if you have an /etc/lilo.conf file. lilo doesn't really work with the new Win 7 MBR. I think grub does work though. You could also use something like EasyBCD to modify the Windows bootloader to include VL.
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

brampieke

  • Member
  • *
  • Posts: 34
Re: Windows can't boot in dual-boot
« Reply #4 on: June 16, 2010, 05:19:25 am »

Code: [Select]
image = /boot/vmlinuz
root = /dev/sda3
label = VectorLinux
append = "splash=silent"
initrd = /boot/initrd
read-only


other = /dev/sda2
label = Windows-sda2
table = /dev/sda

this is what I got.. What do I need to change?
Logged