Author Topic: no <Alt Gr>-type special characters in xterm, pcmanfm,...  (Read 4533 times)


  • Member
  • *
  • Posts: 3
no <Alt Gr>-type special characters in xterm, pcmanfm,...
« on: June 14, 2010, 01:34:34 am »
Hi there!
I've been having some trouble with my keyboard lately. I don't know when it started, but currently the situation is as follows (vector light 6, icewm):
In some applications I can't produce @²³{[]}~\ or any characters requiring (on my german keyboard) the <Alt Gr> modifier (which is the right <Alt> key). Affected applications include at least xterm and pcmanfm. Is there anything I can do about this? I notice xterm also ignores my russian keyboard (pcmanfm doesn't). On the other hand, Firefox and OOOwriter work fine, so it can't be a general X issue (can it?). Still, I'm posting relevant bits of my xorg.conf:
Code: [Select]
Section "InputDevice"
Identifier  "Keyboard0"
Driver      "kbd"
Option  "XkbLayout"  "de,ru,cz"    ## KEYBOARD_MAP!
Option  "XkbOptions" "grp:shift_caps_toggle,grp_led:scroll,lv3:ralt_switch"
Option  "XkbModel"  "thinkpadintl"    ## KEYBOARD_MODEL!
Option  "Xkbvariant"  "deadgraveacute,phonetic,qwerty"    ## KEYBOARD_VARIANT!
Any ideas anyone? Even simply recommending an xterm replacement would help me. rxvt works, but the fonts look ugly.
Best wishes,
« Last Edit: June 14, 2010, 01:37:28 am by rufusD »


  • Vectorian
  • ****
  • Posts: 791
  • it's enough
Re: no <Alt Gr>-type special characters in xterm, pcmanfm,...
« Reply #1 on: June 14, 2010, 08:19:00 pm »
The environment setup read by the shell (presumably bash-as-sh), and thus xterm, isn't done properly when starting X on Light. Haven't had time to go through it, but look at the config/startup files for xdm to get a few good ideas. No other guesses here.