March 28, 2015, 04:46:29 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: No sound at all  (Read 2840 times)
Posts: 2

« on: June 08, 2010, 12:32:08 pm »


I have just installed VL6 on an old PC (celeron 500mhz, 96Mo RAM). Everything works well but I have no sound at all.
After looking in forums, I have used alsamixer to rise levels: no effect.
Also, I have launched alsaconf: it does its job, but no effect...

Before coming to Vector, I have tried other distros (Slitaz, zenwalk) suitable for an old PC: same problem, no sound at all (among other problems for these others distros).
But! I have correct sound with the live CD of DSL.

I have almost no symptom to explain what's happening and as I'm beginner in Linux, I don't know at all where to search... Huh
Just one thing , at the end of alsaconf job, there is a very short message saying something like:
unknown hardware "ens1371" "0x7605..." (followed by figures and letters)
Hardware is initialized using a guess method
/usr/sbin/alsactl set control failed 1266: failed to obtain info for control #23 (no such file or directory)

Any idea to solve that is welcome!
Thank you,

Posts: 6

« Reply #1 on: June 09, 2010, 06:15:09 am »

I feel for you, my friend. I went through the same thing just over a year ago with a brand NEW computer with a very up-to-date sound card. I tried every single tip I could find on the Web to get Alsa to configure my sound card properly, but Nothing worked at all. Finally, I found something on the Arch Linux wiki that saved my bacon - beautifully. It's not a quick or simple solution, but if done properly, it should definitely do the trick.
You should visit the folllowing Wiki page & read it thoroughly:
If you decide to try OSS4, and you install a package for it, you WILL have to install the kernel SOURCE package for whatever kernel your installation has (their package has a shell script that works perfectly exactly as written). Install the kernel sources package 1st, THEN the OSS4 package, and then just run the shell script (it'll be /usr/lib/oss/build/ The script will install the OSS4 modules into your kernel (it will NOT work until you do that). Once you see that it works, if you're happy with it, you can remove the Alsa crap ( /lib/modules/2.6.* /kernel/sound) IF you want to (I did). Just realize one thing: if and when you should ever decide to upgrade the kernel to a newer version, you WILL have to do the same thing again (unless the OSS4 modules are included in your kernel-modules package).
Being new to Linux, it probably sounds a little complicated, naybe even "scary", but you have nothing to lose & everything to gain (it's not as hard as it probably sounds, but it does take some time and effort). Incidentally, the kernel-sources package (which is huge) can be removed after going through all of these steps. The one thing I can definitely tell you is this: after trying OSS4, I myself will NEVER go back to Alsa - period.
Arch's OSS4 package can be downloaded from:
It's the "oss-4.2_2002-2-i686.pkg.tar.gz" package.
All you need to do to install it is just rename it to something like "oss-4.2_2002-i686-2arch.tgz", add an install directory with a brief "slack-desc" file, & then run installpkg.
Read all you can about it 1st. Then, if you want to try it and you get stumped, let me know.
Posts: 2

« Reply #2 on: June 09, 2010, 10:44:51 am »

I'll try!
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!