VectorLinux
April 19, 2014, 07:13:33 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1] 2
  Print  
Author Topic: Belkin F6D4050 v1 (RT2870 drivers) Wireless  (Read 9084 times)
Thera
Member
*
Posts: 10


« on: July 15, 2010, 11:09:48 pm »

Hello,i have one problem with this driver in VL. When i want to use Xp drivers in Ndiswrapper it do this:

Code:
elektron:/~
root:# cd XP_2K
elektron:/~/XP_2K
root:# ndiswrapper
install/manage Windows drivers for ndiswrapper

usage: ndiswrapper OPTION
-i inffile       install driver described by 'inffile'
-a devid driver  use installed 'driver' for 'devid' (dangerous)
-r driver        remove 'driver'
-l               list installed drivers
-m               write configuration for modprobe
-ma              write module alias configuration for all devices
-mi              write module install configuration for all devices
-v               report version information

where 'devid' is either PCIID or USBID of the form XXXX:XXXX,
as reported by 'lspci -n' or 'lsusb' for the card
elektron:/~/XP_2K
root:# ndiswrapper -i rt2870.inf
installing rt2870 ...
elektron:/~/XP_2K
root:# ndiswrapper -l
rt2870 : driver installed
device (050D:935A) present
elektron:/~/XP_2K
root:# ndiswrapper -m
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...
elektron:/~/XP_2K
root:# iwconfig
lo        no wireless extensions.

eth0      no wireless extensions.

elektron:/~/XP_2K
root:# ifconfig wlan0 up
wlan0: ERROR while getting interface flags: No such device
elektron:/~/XP_2K
root:#
 
What im doing wrong?
PS:And sorry for my english..
« Last Edit: July 15, 2010, 11:17:05 pm by Thera » Logged
bigpaws
Vectorian
****
Posts: 1831


« Reply #1 on: July 16, 2010, 03:15:20 am »

Did you use modprobe for ndiswrapper?

The command is (As root):

modprobe ndiswrapper

Did you check to see for ndiswrapper using lsmod?

Bigpaws
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #2 on: July 16, 2010, 03:52:23 am »

I managed to get a similar chipset working using native drivers. This may be of help:
http://forum.vectorlinux.com/index.php?topic=11843
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3134



« Reply #3 on: July 16, 2010, 06:50:37 am »

You may also need firmware
Logged

Thera
Member
*
Posts: 10


« Reply #4 on: July 17, 2010, 01:36:45 am »

Did you use modprobe for ndiswrapper?

The command is (As root):

modprobe ndiswrapper

Yes
Code:
root:# ndiswrapper -m
adding "alias wlan0 ndiswrapper" to /etc/modprobe.d/ndiswrapper ...

Did you check to see for ndiswrapper using lsmod?
Code:
root:# lsmod
Module                  Size  Used by

ndiswrapper           185500  0
Logged
Thera
Member
*
Posts: 10


« Reply #5 on: July 17, 2010, 01:41:39 am »

You may also need firmware

When i use drivers and firmware from Ralink:

Code:
elektron:/~/LINUXSTA/os/linux
root:# insmod rt2870sta.ko
elektron:/~/LINUXSTA/os/linux
root:# ifconfig ra0 up   
ra0: ERROR while getting interface flags: No such device

Why i still cant bring up the interface?..
Logged
Thera
Member
*
Posts: 10


« Reply #6 on: July 17, 2010, 01:45:47 am »

And maybe this can help..Dmesg output
Code:
sda: sda1
sd 2:0:0:0: [sda] Attached SCSI removable disk
sd 2:0:0:0: Attached scsi generic sg0 type 0
usb-storage: device scan complete
usb 1-1: USB disconnect, address 3
usb 1-1: new full speed USB device using uhci_hcd and address 4
usb 1-1: configuration #1 chosen from 1 choice
usb 1-1: reset full speed USB device using uhci_hcd and address 4
ndiswrapper (import:242): unknown symbol: ntoskrnl.exe:'MmGetSystemRoutineAddress'
ndiswrapper (load_sys_files:206): couldn't prepare driver 'rt2870'
ndiswrapper (load_wrap_driver:108): couldn't load driver rt2870; check system log for messages from 'loadndisdriver'
Logged
bigpaws
Vectorian
****
Posts: 1831


« Reply #7 on: July 17, 2010, 05:47:38 am »

There is kernel support for this Wireless chipset from kernel
version 2.6.30.5.

If you have this kernel you probably do not need ndisdwrapper
which may be having a conflict.

Check uname -r

Bigpaws
Logged
Thera
Member
*
Posts: 10


« Reply #8 on: July 18, 2010, 06:33:21 am »

There is kernel support for this Wireless chipset from kernel
version 2.6.30.5.

If you have this kernel you probably do not need ndisdwrapper
which may be having a conflict.

Check uname -r

Bigpaws

Code:
root:# uname -r
2.6.27.12
Logged
bigpaws
Vectorian
****
Posts: 1831


« Reply #9 on: July 18, 2010, 08:34:54 am »

Please post the output of lsmod


Bigpaws
Logged
Thera
Member
*
Posts: 10


« Reply #10 on: July 20, 2010, 04:26:38 am »

Please post the output of lsmod


Code:
LSMOD Output:

root:# lsmod
Module                  Size  Used by
radeon                141472  0
drm                    70824  1 radeon
ndiswrapper           185500  0
lp                     10372  0
snd_seq_dummy           3716  0
snd_seq_oss            31872  0
snd_seq_midi_event      6912  1 snd_seq_oss
snd_seq                48368  5 snd_seq_dummy,snd_seq_oss,snd_seq_midi_event
snd_seq_device          7436  3 snd_seq_dummy,snd_seq_oss,snd_seq
snd_pcm_oss            37408  0
snd_mixer_oss          15104  1 snd_pcm_oss
speedstep_lib           4740  0
acpi_cpufreq            7948  0
freq_table              4352  1 acpi_cpufreq
8139too                23936  0
snd_intel8x0           29980  2
mii                     5376  1 8139too
snd_ac97_codec         99492  1 snd_intel8x0
rtc_cmos               10144  0
rtc_core               15132  1 rtc_cmos
ac97_bus                2432  1 snd_ac97_codec
rtc_lib                 3328  1 rtc_core
snd_pcm                67972  3 snd_pcm_oss,snd_intel8x0,snd_ac97_codec
snd_timer              19976  2 snd_seq,snd_pcm
serio_raw               6020  0
snd                    51492  14 snd_seq_dummy,snd_seq_oss,snd_seq,snd_seq_device,snd_pcm_oss,snd_mixer_oss,snd_intel8x0,snd_ac97_codec,snd_pcm,snd_timer
soundcore               7008  1 snd
snd_page_alloc          8840  2 snd_intel8x0,snd_pcm
shpchp                 29716  0
iTCO_wdt               10916  0
pci_hotplug            27040  1 shpchp
parport_pc             35908  1
irda                  108984  0
parport                31724  2 lp,parport_pc
crc_ccitt               2688  1 irda
video                  17040  0
output                  3456  1 video
asus_laptop            16376  0
led_class               4484  1 asus_laptop
joydev                 10048  0
evdev                  10144  7
Logged
Thera
Member
*
Posts: 10


« Reply #11 on: July 20, 2010, 07:40:00 am »

heh,i have one idea...

maybe when i will reinstall VectorLinux and install newest kernel for VL (kernel-2.6.31.8 from http://vectorlinux.osuosl.org/veclinux-6.0/kernels/)...maybe it can solve my problem?...
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #12 on: July 20, 2010, 11:35:20 am »

Kernel 2.6.31.8 does not have the modules included. Did you try using the native drivers as I mentioned in my post above?
Logged
Thera
Member
*
Posts: 10


« Reply #13 on: July 21, 2010, 07:12:43 am »

Kernel 2.6.31.8 does not have the modules included. Did you try using the native drivers as I mentioned in my post above?

Yes,i followed the instructions correctly but i still dont see any wlan0 or ra0 in iwconfig output and i cant still cant bring up the interface...
Logged
nightflier
Administrator
Vectorian
*****
Posts: 3941



« Reply #14 on: July 21, 2010, 09:07:53 am »

If you installed the native drivers plus ndiswrapper, that would probably lead to a conflict.
Try some manual troubleshooting; as root, in a terminal:
Code:
modprobe -r ndiswrapper
modprobe -r rt2800usb
modprobe rt2870sta
VLwifi
Logged
Pages: [1] 2
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!