VectorLinux
November 26, 2014, 01:18:26 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Lilo can't start win7  (Read 1585 times)
brampieke
Member
*
Posts: 34


« on: July 20, 2010, 01:23:58 am »

hello,


 I got a question. I'm using LILO to let my dualboot (vector and win7) working. Vector works but Win7 doesn't. It says that boot MBR is missing. I've tried some things but so far nothing worked. Any Ideas? Or would it be better to use grub?

Code:
default = VectorLinux
image = /boot/vmlinuz
root = /dev/sda3
label = "VectorLinux"
append = "splash=silent"
initrd = /boot/initrd
read-only

optional
other = /dev/sda2
label = "Win7"

I've also noticed that when I change things in this code that i doesn't have an effect on my lilo-screen. Is this normal?
Logged
M0E-lnx
Administrator
Vectorian
*****
Posts: 3192



« Reply #1 on: July 20, 2010, 05:40:23 am »

Windows 7 is known to have this problem with both lilo and grub.

You'll find a work around here http://forum.vectorlinux.com/index.php?topic=11276.0

Google around and you'll see tons of people are having this problem. Most of us have solved it by wiping out any remains of any windows install ever, but those who choose to have them will face ... well, you know.. the MBR problem with windows 7 Wink
Logged

never_stop_learning
Vectorite
***
Posts: 263


WWW
« Reply #2 on: July 26, 2010, 02:01:08 pm »

Used Puppy to install GRUB for a Win7 - VL 6.0 dual boot.....worked great.
Logged

Laptop: IBM X60s (Centrino/Duo, 2gb ram, 80gb hd) VL 6.0 Std
Netbook: HP Mini (Intel Atom 1ghz, 2gb ram, 16gb SSD + 8gb flash ) VL 6.0 Std
Desktop: Dell Dimension 5150 (P4 3ghz, 2gb ram, 80gb hd) VL 6.0 Std
Wife's Desktop: Gateway (P4 2ghz, 1gb ram, 80gb hd) VL 6.0 Std
retired1af
Packager
Vectorian
****
Posts: 1267



« Reply #3 on: July 27, 2010, 05:12:03 am »

Rather than messing with partitioning the Windows drive (I'm using Win 7 as well), I purchased an inexpensive external USB drive and dedicated it solely to Linux. I then set up the boot order on the notebook to look for the USB drive first. If the USB drive is not plugged in, it defaults to the Windows drive. I've finally managed to track down a drive caddy that is designed for the second drive bay on the notebook, so I may end up going that route and using the USB drive as a backup device.

As for the lilo changes, whenever you make changes to lilo.conf, you should run lilo -v at the cli. This will commit the changes you make to the configuration file.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!