VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Eclipse constantly crashes in VL6 SOHO  (Read 2749 times)

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Eclipse constantly crashes in VL6 SOHO
« on: July 20, 2010, 11:53:51 am »

I have downloaded and tried Eclipse Europa and Helios versions (binary tarballs) but they always crash very soon after load by doing just about anything,  from trying to create a project to launching the help. There is a lot of stuff in the error logs it leaves, but the only readable part is this:
Code: [Select]
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0xb1ffad8e, pid=27409, tid=3077499088
#
# JRE version: 6.0_20-b02
# Java VM: Java HotSpot(TM) Client VM (16.3-b01 mixed mode, sharing linux-x86 )
# Problematic frame:
# C  [libxpcom_core.so+0x51d8e]
#

I have upgraded java several times with the VL packages, and am currently using jre-6u20-i586-1vl60. Any ideas?
« Last Edit: July 21, 2010, 02:17:02 pm by Joe1962 »
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #1 on: July 20, 2010, 12:09:30 pm »

Did you try stracing it?

What are you using eclipse for? you doing java now?

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #2 on: July 20, 2010, 12:22:57 pm »

Did you try stracing it?
I have never done that before and I am not sure I would understand what I would get from it... :-[

What are you using eclipse for? you doing java now?
I am "trying" to use it... ;D  There is a lot of development going on here at my work in java and I figured I better learn me some java to at least understand what they are doing. Also, a colleague wants to do php development in linux, so I also downloaded the eclipse php stuff to show her (she has only used winders before, I am weaning her on VL6 SOHO).
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #3 on: July 20, 2010, 12:34:54 pm »

Nice on the vl intro.. ;)

I've used eclipse before in VL light 6... not sure what is keeping you from running it on SOHO. Do you have enough ram? because eclipse, although it is a good looking IDE, is also a ram hog.

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #4 on: July 20, 2010, 12:43:51 pm »

2 GB.


EDIT: I just remembered, I also tried a Slackware package from slacky.eu, same issue.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #5 on: July 20, 2010, 12:51:48 pm »

You're not the only one... the brown guys also had this problem and it looks like it's linked to the PHPeclipse browser

see here http://ubuntuforums.org/showthread.php?t=429416

I dont know how to get around it though... evey time I used eclipse was for python never for PHP

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #6 on: July 20, 2010, 12:57:05 pm »

But it also happens in the eclipse-c++ tarball.

BTW, just tried "strace /opt/eclipse/eclipse" and it only got to a halfway finished gui and locked all of X. Alt-F2, htop, kill eclipse, then I got X back... ???
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #7 on: July 20, 2010, 12:58:39 pm »

Found a suggested fix for you... try it out and see if it works. http://lists.slackbuilds.org/pipermail/slackbuilds-users/2010-June/005979.html

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #8 on: July 20, 2010, 01:23:05 pm »

Dang! Thanks M0E-lnx... ;D  I had googled myself out on this issue about a month ago. That post is newer, from the 17th July!

First I tried installing xulrunner from the repo, but then I got a libpng related error (we have updated libpng recently, so maybe we need a new xulrunner build). The second solution, editing eclipse.ini to point to /usr/lib/seamonkey seems to have worked like a charm. I will post it here for the record:
Code: [Select]
edit /opt/eclipse/eclipse.ini and (below the '-vmargs' line) add the following line:
-Dorg.eclipse.swt.browser.XULRunnerPath=/usr/lib/seamonkey

BTW: they mention it doesn't work with firefox.
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #9 on: July 20, 2010, 01:30:40 pm »

Cool, you got it worked out.

I might pick up java myself too. been wanting to get into android development

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: SOLVED - Eclipse constantly crashes in VL6 SOHO
« Reply #10 on: July 21, 2010, 01:24:44 pm »

Oh, boy... Crashes are still there, just not so often... >:(
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: SOLVED - Eclipse constantly crashes in VL6 SOHO
« Reply #11 on: July 21, 2010, 01:28:01 pm »

hehe... Is there any other IDE that can be used for JAVA? I find eclipse too clumsy and slow to work with.

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #12 on: July 21, 2010, 02:20:02 pm »

Well, there's netbeans, but I can't get to it from here, and according to recent opinions, it's going to die...

http://blogs.computerworld.com/node/16570/print

Quote
Oracle has decided to let OpenSolaris die by benign neglect. It’s also a policy that they’re using with other Sun open-source projects. I predicted that Oracle would do this after the company acquired Sun to projects like NetBeans, the IDE (integrated development environment) that competes with Oracle’s own IDE of choice Eclipse. I’m now being told at OSCon [5] in Portland, OR by people close to Sun and Oracle that that’s exactly what’s happening.


EDIT: BTW, I have been told that netbeans is also resource-hungry... >:(
« Last Edit: July 21, 2010, 02:29:45 pm by Joe1962 »
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Eclipse constantly crashes in VL6 SOHO
« Reply #13 on: July 21, 2010, 08:52:09 pm »

I've found out that java (and development) are by nature resource hogs