VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Synaptics Touchpad - How to disable?  (Read 1817 times)

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1342
Synaptics Touchpad - How to disable?
« on: July 28, 2010, 06:20:17 am »

I'm assuming that the touchpad is identified as "mouse1" in the configuration. Problem is, there isn't a xorg.conf to monkey with in SOHO 6 Beta. Soooooo, where exactly do I look to comment the mouse1 line out?
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3280
Re: Synaptics Touchpad - How to disable?
« Reply #1 on: July 28, 2010, 06:33:19 am »

You can find the correct ID value from /proc/bus/input/devices

I guess you could just take out the section for that device in your xorg.conf

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: Synaptics Touchpad - How to disable?
« Reply #2 on: July 28, 2010, 07:22:12 am »

You need to disable it in HAL.

HAL and udev are now the device controllers. If you need or want changes for
devices this is the likely place to do it.

I found this for disabling a touchpad:

http://crunchbanglinux.org/forums/topic/2835/how-to-completely-turn-off-a-touchpad/

Bigpaws
Logged

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1342
Re: Synaptics Touchpad - How to disable?
« Reply #3 on: July 29, 2010, 05:53:47 am »

Thanks Bigpaws! That was the clue I needed to get the blasted thing turned off.

The instructions were a little more **cough** detailed than what's really needed. In essence, find the .fdi file, copy it to /etc/hal/fdi/policy, then make the edit in the first section of the file. Add synclient touchpadoff=1 to rc.local and you're golden!
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1342
Re: Synaptics Touchpad - How to disable?
« Reply #4 on: August 01, 2010, 08:13:40 am »

I've run into an issue, and am a bit confused as to why this isn't working as it should.

I added /usr/bin/synclient touchpadoff=1 to rc.local, but it's not taking effect. However, typing the command works just fine at the cli. What am I missing?
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

bigpaws

  • Vectorian
  • ****
  • Posts: 1872
Re: Synaptics Touchpad - How to disable?
« Reply #5 on: August 01, 2010, 08:27:01 am »

Check your permissions.

rc.local is run as root.

Bigpaws
Logged

retired1af

  • Administrator
  • Vectorian
  • *****
  • Posts: 1342
Re: Synaptics Touchpad - How to disable?
« Reply #6 on: August 01, 2010, 08:57:27 am »

Huh? Yes, I know rc.local is run as root. However, it seems that the synclient command is being ignored. There's nothing in /var/log/messages that even shows it is being run at all.
Logged
ASUS K73 Intel i3 Dual Core 2.3GHz

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4141
Re: Synaptics Touchpad - How to disable?
« Reply #7 on: August 01, 2010, 12:59:56 pm »

I suspect that rc.local is processed before X (and the synaptics driver), so the command won't do anything at that point.

Add the command to your DE (xfce, kde, gnome... ) startup, as regular user.
Logged