VectorLinux
October 24, 2014, 09:22:32 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: HOWTO: Disable Synaptics touchpad in VL SOHO 6  (Read 5204 times)
retired1af
Packager
Vectorian
****
Posts: 1264



« on: July 29, 2010, 05:19:09 am »

I had disabled the touchpad on my Toshiba notebook via the BIOS and wasn't really concerned with using it, as I usually have my mouse close at hand. However, since I'm traveling much more often now, I had whipped my notebook out in an airport to check email and didn't feel like digging the mouse out, too. Forgot I had disabled the touchpad. Duh!

On the Windows side of the notebook, the touchpad is disabled as soon as the mouse is plugged in. However, there's no such option right now on the Linux side (something to dig into later!). Soooooooo, how to disable the touchpad without booting into the BIOS everytime I need it?

The instructions that follow are for a Synaptics touchpad. They may give a clue on how to proceed if yours is different.

________________________________________

First:

Code:
cp /usr/share/hal/fdi/policy/20thirdparty/11-x11-synaptics.fdi /etc/hal/fdi/policy/11-x11-synaptics.fdi

Now we need to add the instructions to the file that allows us to turn the touchpad on and off.

Using your favorite text editor, edit /etc/hal/fdi/policy/11-x11-synaptics.fdi and look for the section that starts with <match key="info.product" contains="Synaptics TouchPad">. Add the following at the end of that section:

Code:
<merge key="input.x11_options.SHMConfig" type="string">On</merge>

Restart your machine so the changes take effect.

The following can now be typed (as root) at the cli:

Code:
/usr/bin/synclient touchpadoff=1

Enjoy!

Edit -- You can create a quick script, make it executable, then toss it in your /home/loginid/.kde/Autostart directory to have this run each time you start the machine.
« Last Edit: August 05, 2010, 01:37:11 pm by retired1af » Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #1 on: July 29, 2010, 05:50:09 am »

A slightly off-topic note: If you are using VL6 Light or KDE-Classic, some of these steps may not be necessary.

The installer should offer to activate the touchpad driver. If accepted, this is one of the functions available. The command "synclient touchpadoff=1" can be run as normal user and it does disable the pad. There is also a little script /sbin/vtptoggle that will do this for you. On my laptop, I mapped a keyboard combination for this action.

I also include the command "syndaemon -d -i 0.8" in my KDE Autostart. This disables the pad as soon as I start typing, and re-enables it 0.8 seconds after I stop.
Logged
retired1af
Packager
Vectorian
****
Posts: 1264



« Reply #2 on: July 29, 2010, 05:55:02 am »

I'm going to play around with creating a routine that allows the system to detect whether the mouse is plugged in, and if so, disables the touchpad. Should be fun. Maybe.  Grin
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #3 on: July 29, 2010, 07:12:23 am »

Thanks to both of your for this. I would have tried it immediately, but I'm finding that the touchpad on my new-to-me Dell Inspiron 1100 is well behaved and when used with a USB mouse, doesn't do the annoying things all the other touchpads I've used do. So I'm giving it a chance to stay unobtrusive and will leave it activated if it continues behaving. It's occasionally handy to have the touchpad.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
retired1af
Packager
Vectorian
****
Posts: 1264



« Reply #4 on: July 29, 2010, 07:53:20 am »

Unfortunately, my touchpad isn't so well behaved. And the heel of my right palm rests on the edge of the touchpad, making typing an infuriating experience when it's active.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Deach
Vectorite
***
Posts: 168


« Reply #5 on: August 05, 2010, 05:54:41 am »

I'm not on my vector box just now but there is a way to disable touch pad while typing.  um....somethinig about syndaemon I believe.....I have it in startup on my VL laptops.  I'll look when I get home.
Logged

Inspiron 4000 Laptop, VL 6.0  600 mhz; 384 ram : Inspiron1100 VL 6.0
Inspiron B120 & B130 Laptop, VL 6.0  1. 4& 1.5  ghz; 1gig ram
IBM Thinkpad Laptop, VL 6.0  1.5 ghz;  1 gig ram
Dark Rider
Member
*
Posts: 65


« Reply #6 on: February 06, 2013, 03:30:06 am »

I can't get this to work in Vlocity 7.0. Under 20thirdparty I only have a file called 90-grant-audio-devices-to-gdm.fdi. I know with other XFCE versions like in Mint 14, there is a disable this device radio button, but it's not in Vlocity under the mouse/touchpad section of Settings.

Tried using Catfish to find 11-x11-synaptics.fdi but it's not found. Not even is synaptics found. I assume this how to was written for an older version of Vector.

Edit: Bah. I see after I posted, this was for version 6 but when you search the forums some of the titles are turnicated so I didn't know.. still this is the only thread on this topic i've found.
« Last Edit: February 06, 2013, 03:35:30 am by Dark Rider » Logged
retired1af
Packager
Vectorian
****
Posts: 1264



« Reply #7 on: February 06, 2013, 04:05:02 am »

I'll play around with this later this week. My new notebook also has a synaptics touchpad. I haven't gotten around to see if I can use the same instructions to kill it.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
overthere
Vectorian
****
Posts: 1281



« Reply #8 on: February 06, 2013, 04:19:44 am »

gsynaptics via gslapt will allow toggle of the touchpad or tapping with a click of the mouse. this is for 32 bit so perhaps is not available for 64 yet. worth a look, even if not available perhaps can be.
Logged

Everything Is Relative
hata_ph
Packager
Vectorian
****
Posts: 3258


-- Just being myself --


« Reply #9 on: February 06, 2013, 04:38:32 am »

run synclient touchpadoff=1 in terminal will disable your touchpad...
run synclient touchpadoff=0 to enable the touchpad again...

http://crunchbang.org/forums/viewtopic.php?id=15992
Logged
Dark Rider
Member
*
Posts: 65


« Reply #10 on: February 06, 2013, 05:39:32 am »

Thanks for the info folks. I'll use hata_ph's solution for now until something better comes along. I did try gsynaptics and it works in 64 bit but it doesn't toggle the touchpad on or off for me.
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #11 on: February 06, 2013, 01:53:17 pm »

If gsynaptics is in the 64 bit repository and does not turn off your synaptic touch pad when you uncheck the box enable touch pad then it does not work and should not be there.
Logged

Everything Is Relative
retired1af
Packager
Vectorian
****
Posts: 1264



« Reply #12 on: February 06, 2013, 03:26:43 pm »

If I can remember to turn on the touchpad when I turn the notebook on, I'll test out the package.
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Dark Rider
Member
*
Posts: 65


« Reply #13 on: February 06, 2013, 04:58:36 pm »

If gsynaptics is in the 64 bit repository and does not turn off your synaptic touch pad when you uncheck the box enable touch pad then it does not work and should not be there.

My mistake. I looked again and found the check box. I must have missed it somehow. Yes, it does work. Thanks !
Logged
overthere
Vectorian
****
Posts: 1281



« Reply #14 on: February 06, 2013, 11:43:05 pm »

Thanks for the confirmation, this suggests then that for VL7 32 and 64 bit systems, synaptic touchpads can be toggled off or on via terminal or via gsynaptics application as posted above.

For those who use the touch pad and do not want tapping enabled it can be toggled off by clicking the tapping tab in gsynaptics and unchecking the box enable tapping.
Logged

Everything Is Relative
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!