VectorLinux
October 24, 2014, 11:32:06 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Compiling Alsa  (Read 2419 times)
stanz0
Member
*
Posts: 12



« on: August 13, 2010, 05:59:24 pm »

So, I've decided to compile alsa.
This to get my sound card working.

I first did ./configure --with-cards=maestro3 --with-sequencer=yes


Then I did make, then make install.


Make install gave this result:

rm -f /lib/modules/0.0.0/misc/snd*.*o /lib/modules/0.0.0/misc/persist.o /lib/modules/0.0.0/misc/isapnp.o
make[1]: Entering directory `/home/grim0x/Downloads/alsa-driver-1.0.9b/acore'
mkdir -p /lib/modules/0.0.0/misc
cp snd-hpet.o snd-page-alloc.o snd-pcm.o snd-timer.o snd.o /lib/modules/0.0.0/misc
cp: cannot stat `snd-hpet.o': No such file or directory
cp: cannot stat `snd-page-alloc.o': No such file or directory
cp: cannot stat `snd-pcm.o': No such file or directory
cp: cannot stat `snd-timer.o': No such file or directory
cp: cannot stat `snd.o': No such file or directory
make[1]: *** [_modinst__] Error 1
make[1]: Leaving directory `/home/grim0x/Downloads/alsa-driver-1.0.9b/acore'
make: *** [install-modules] Error 1


Whats going on here?
Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #1 on: August 14, 2010, 09:31:42 pm »

Did you su to root before running make install? You need to as this stage of the process needs root permission to copy files to the system folders.
Andy
Logged
stanz0
Member
*
Posts: 12



« Reply #2 on: August 15, 2010, 07:16:50 pm »

Yes Andy, that I did...
Logged
Andy Price
Packager
Vectorite
****
Posts: 237


« Reply #3 on: August 16, 2010, 02:36:20 am »

 I did a bit of googling and found exactly the same problem posted on an Ubuntu forum (http://www.ge.ubuntuforums.org/showthread.php?t=1538544) so you are not alone - but unfortunately no solution was offered. As far as I know, stat errors indicate either permission problems or that the file can't be found. I presume there were no errors indicated during configure? Hopefully someone else will chime in here with some ideas.
Logged
stanz0
Member
*
Posts: 12



« Reply #4 on: September 04, 2010, 12:45:36 pm »

bumpy
Logged
The Headacher
Louder than you
Global Moderator
Vectorian
*****
Posts: 1551


I like the bass to go BOOM!


WWW
« Reply #5 on: December 30, 2010, 07:54:06 am »

Are you sure you want to compile an alsa that old (1.0.9b?). The current one is 1.0.23...
Logged

Most music on my soundcloud page was arranged in programs running on VL.
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!