VectorLinux
November 23, 2014, 06:37:00 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 20100820 spkg-1.0rc13 [VL6.0]  (Read 797 times)
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« on: August 20, 2010, 12:04:56 pm »

toothandnail has built a new Spkg package for VectorLinux 6.0.
   
      
   
Code:
spkg: spkg (the unofficial Slackware package manger)
spkg:
spkg: spkg, the unofficial Slackware package manager. Written in C, spkg
spkg: is optimzed for speed.
spkg:
spkg:
spkg:
spkg: License: GPL
spkg: Authors: Ondřej Jirman
spkg: Website: http://spkg.megous.com/
   
   After testing this package please stop back here and let us know how it works for you.
   
Logged
Pita
Vectorian
****
Posts: 1311


« Reply #1 on: August 22, 2010, 07:13:16 pm »

I can't get it to work.

 sudo spkg -i gedit-2.31.3.tgz
ERROR: Package name is invalid. (gedit-2.31.3.tgz)
ERROR: Package installation failed!

I get the same error with other packages I have tried
which I can install or upgrade with the install-/upgradepkg command.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #2 on: August 23, 2010, 05:31:51 am »

I can't get it to work.

 sudo spkg -i gedit-2.31.3.tgz
ERROR: Package name is invalid. (gedit-2.31.3.tgz)
ERROR: Package installation failed!

I get the same error with other packages I have tried
which I can install or upgrade with the install-/upgradepkg command.


How did you install it? It does have a dependency, which means it will probably fail unless installed with slapt-get/gslapt. Any package announced here should be installed using the package manager, otherwise there is no guarantee that it will be correctly installed.

It works here. Took me a while to find a package in .tgz format, but I did find an old Zenwalk package I built several years ago. Results are as below:

Code:
root:# spkg -i pinfo-0.6.9-i486-50.1.tgz
Installing package pinfo-0.6.9-i486-50.1...
| 'pinfo (a hypertext info file viewer)
|
| Pinfo is a hypertext info file viewer with a user interface similar to
| lynx. It is based on curses/ncurses, and can handle man pages as well
| as info pages. Features regexp searching and user-defined colours/keys
|
| Written by Bas Zoetekouw
|
|
|
|
|
|
install-info: warning: no info dir entry in `accounting.info.gz'
install-info: warning: no info dir entry in `gtkdialog.info.gz'
install-info: warning: no info dir entry in `termcap.info.gz'
install-info: warning: no info dir entry in `time.info.gz'
install-info: warning: no info dir entry in `which.info.gz'

The warnings are generated by info, and reflect errors in the existing info.dir, but the package installs and works fine.

Paul.
Logged
Pita
Vectorian
****
Posts: 1311


« Reply #3 on: August 24, 2010, 12:03:37 am »

Yes it is looking for glib2-2.24 which I do not have in my VL6 box and cannot
find with gslapt. I can see it in VL7 iso file.
Logged
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« Reply #4 on: August 24, 2010, 06:12:51 am »

Yes it is looking for glib2-2.24 which I do not have in my VL6 box and cannot
find with gslapt. I can see it in VL7 iso file.

Hmm. I'm not at all sure how, but you've got the wrong build - either the version for 6.0 SOHO or the build for the 7.0 alpha. This is the dep list for the VL 6.0 version, taken direct from the repo:

Code:
PACKAGE REQUIRED:  aaa_base >= 12.1.0-noarch-2 | glibc-solibs >= 2.7-i486-10,glib2 >= 2.16.3-i586-
1gsb,judy >= 1.0.5-i586-1vl60,popt >= 1.7-i486-2,zlib >= 1.2.3-i486-2

You should have a .tlz package, not a .txz.

Paul.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!