VectorLinux
October 31, 2014, 01:35:23 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Atheros 5006 Wireless network problems with Live CD  (Read 1351 times)
essenby
Member
*
Posts: 3


« on: August 23, 2010, 03:05:31 am »

Hi,

I have a Tosh Satellite A100 laptop which has an Atheros 5006 on board wireless network card (full specs here) and I'm thinking of replacing Widoze Vista so I tried the VL6.0-KDE-Classic-Live CD exerything starts up great, but although it shows that I have a functioning wireless dvice on wlan0, it does not appear to be able to scan for, or locate any wireless networks.  The wlan0 is a bit unusual as other distros I have tried have nearly always named it ath0.  Is this an indication that the card has not been recognised correctly and therefore not using the correct modules/drivers? 

Any ideas what I can check/try/tweak to get my wireless card recognised and working correctly?
« Last Edit: August 24, 2010, 04:00:35 am by essenby » Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #1 on: August 23, 2010, 03:52:36 am »

As root, run "/sbin/VLwifi". It should give you the name of your wireless device.

You can change the settings in the wicd network manager by left-clicking on the tray icon, then the "Preferences" box.
Logged
essenby
Member
*
Posts: 3


« Reply #2 on: August 24, 2010, 12:50:52 am »

Tried that and VLwifi tells me that it has found a network device wlan0 and prompts for essid and WEP key but does not make the connection.

Setting the Preferences in wicd has exactly the same non-effect :-(

It's a shame really, the VL interface is really nice to use and it really flies - but if I can't get the network connection it's a bit of a non starter for me.
Logged
nightflier
Administrator
Vectorian
*****
Posts: 4026



« Reply #3 on: August 24, 2010, 03:55:01 am »

It is very possible that the wrong driver gets loaded. I believe the options would be "ath_pci", "ath5k" (maybe ath9k) or ndiswrapper.

Wireless is not my strong point. I suggest adding "Atheros 5006" to the title of your original post, maybe we'll attract the attention of someone who uses that chipset.

It would be helpful if you could post the output of the command "lsmod".
Logged
essenby
Member
*
Posts: 3


« Reply #4 on: August 24, 2010, 04:05:29 am »

I tend to agree - ath5k is probably the most suitable and I'm sure this is the one used by those distros that work flawlessly.  Unfortunately my (total) lack of knowledge precludes me from changing which driver is used or ensuring it is loaded automatically Sad

I'm not at the laptop right now but I'll post lsmod output when I get the chance

EDIT
I've just done what I should have done first off and read all the FAQ's and stickies etc.  I've just found this HowTo so I'll work through that and post back if I srtill have issues.

Fingers crossed  Embarrassed
« Last Edit: August 24, 2010, 04:26:52 am by essenby » Logged
roarde
Vectorian
****
Posts: 538


move the needle


« Reply #5 on: August 26, 2010, 08:17:46 pm »

I have ath2k card. VL calls it wlan0, and that works.

On the other hand, isn't KDE live the one that doesn't have wireless interface filled in in wicd? Go back to preferences, you'll see the wired connection is eth0 or some such, but wireless isn't filled in. Make it wlan0.
Logged

Robert
VL STD 7.1 RC2.2.2, icewmvmods
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!