VectorLinux
July 31, 2014, 01:18:07 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: Odd Wicd behavior  (Read 2157 times)
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« on: August 25, 2010, 09:28:56 am »

I am using a TRENDnet USB wireless adapter on a Dell Inspiron 1100 under VL6 Light. it has a Ralink RT2870 chip with a Linux driver from Ralink. It is working very well, strong signal, stable. When VL6 Light starts, there is a correct RA0 connection running. When I start IceWM, the Wicd icon in the system tray shows that I'm connected.

However, I can't get on the Internet. In order to get on the Net I have to open Wicd, disconnect from the wireless connection, and connect again. Then I can get on the Net.

Why do I have to run Wicd as user even though the connection is already active, according to ifconfig, iwconfig, and wicd? It's a small annoyance but I'd like to fix it if I could.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
bigpaws
Vectorian
****
Posts: 1844


« Reply #1 on: August 26, 2010, 05:58:28 am »

Iirc I had this happen at one time. Check the version of Wicd it should be 1.7.0.

Have you tested to see where the problem lies, like DNS? Can you scan the network?

My resolution wound up being to setup inet1.conf for a connection.

Bigpaws
Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2499



WWW
« Reply #2 on: August 26, 2010, 09:34:29 am »

I don't know if this is related, but I have seen a situation where on the wired network here it would start up with DHCP instead of the settings configured in wicd. I figured out that on those occasions, the connection was getting set up by the normal linux networking scripts with the config from /etc/rc.d/inet1.conf, so I set this up for my most used values. I believe, but have not really researched this scientifically, that it would happen when I started up the laptop without the cable plugged in. I have not seen this in SOHO 6 Final, but then it has only been installed for about a week and I may simply not have forgotten to plug the cable in on boot up yet... Grin
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #3 on: August 26, 2010, 06:14:50 pm »

The wicd version is  1.7.0. I don't see anything wrong,  but I really don't know what to  look for. I use fixed IP addresses and global DNS to my  ISP's DNS servers.

I don't have a wired  connection on this laptop, no cable plugged in. I did rename /rc.d/rc.inet1  to rc.inet_original; rc.inet1 was for a wired connection that I had set up briefly until the wireless adapter arrived. I copied rc.inet3 (wireless connection) to rc.inet1 so that they are now duplicates. I'll see if that changes anything. The wireless connection is the one that comes up when VL6 Light starts.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #4 on: August 27, 2010, 02:37:13 pm »

I was able to get on the Net right away when I started IceWM today. I didn't have to use wicd to disconnect and then connect with wicd.

I suspect that copying rc.d/inet3 to rc.d/inet1 is what did it.

Thanks for the clues! Now I'll keep my fingers crossed that my wireless connection will keep behaving.<g>
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #5 on: August 29, 2010, 06:38:50 pm »

Well, the "fix" didn't last. It made it through one reboot but ever since, I have to disconnect with wicd and then connect again. I can't see what's wrong. DNS addresses are correct. Wicd settings are correct.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
bigpaws
Vectorian
****
Posts: 1844


« Reply #6 on: August 30, 2010, 03:24:10 am »

Have you checked that the WICD daemon was not running?

Bigpaws
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #7 on: August 31, 2010, 08:43:24 pm »

The wicd daemon is running at startup. ifconfig and iwconfig show that ra0 is set up and working. Yet I can't connect to the Internet then. I have to use wicd to disconnect and then connect again. After that I can get on the Internet.

I can live with this, but it would be better to have a fix if there is one.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
bigpaws
Vectorian
****
Posts: 1844


« Reply #8 on: September 01, 2010, 04:42:56 am »

I would try disabling /etc/rc.d/rc.wicd.

Bigpaws
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #9 on: September 02, 2010, 09:36:20 pm »

I would try disabling /etc/rc.d/rc.wicd.

I tried it but it made no difference. I have given up and will simply disconnect and reconnect when I first start IceWM. I'm sure there's a reason but I can't find it. Everything looks okay. At least it's working very well except for that startup glitch!
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #10 on: September 02, 2010, 10:34:27 pm »

Don't give up yet! Check /etc/rc.d/rc.local for a wicd entry.
Logged
GrannyGeek
Packager
Vectorian
****
Posts: 2567


« Reply #11 on: September 04, 2010, 07:53:00 pm »

Don't give up yet! Check /etc/rc.d/rc.local for a wicd entry.

What would that do for me? Wicd loads and is active as soon as VL6 Light loads. I can  ping the Internet and the local network right away. ifconfig and iwconfig show that ra0 (the wireless connection) is active right from the start. When I start IceWM, the wicd icon appears in the tray and shows that I'm connected to my wireless network. Yet I can't get on the Internet until I click on Disconnect in wicd and then click on Connect. Everything is fine then.

I'm wondering about some DNS problem the first time I try to connect to the Internet without disconnecting and reconnecting. But the addresses in /etc/resolv.conf are correct and they are the same as the Global DNS Server addresses I use in wicd. And when I reconnect I don't change anything, so the DNS servers in wicd don't get changed when I restart the connection.

I'm not very good at understanding man pages, but I'm going to go through the man pages for wicd to see if anything jumps out at me.

Again, this is a minor problem that it takes me about 15 seconds to handle. A solution is not urgent, just a matter of curiosity as much as anything.
--GrannyGeek
Logged

Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller
nightflier
Administrator
Vectorian
*****
Posts: 4018



« Reply #12 on: September 05, 2010, 03:34:11 am »

Misunderstood, thought you wanted to disable wicd.
Logged
retired1af
Packager
Vectorian
****
Posts: 1253



« Reply #13 on: September 05, 2010, 03:53:06 am »

MOAR COFFEE!  Grin
Logged

ASUS K73 Intel i3 Dual Core 2.3GHz
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!