VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Mount Samsung phone <solved>  (Read 7091 times)

InTheWoods

  • Vectorite
  • ***
  • Posts: 302
Mount Samsung phone <solved>
« on: June 15, 2009, 10:42:46 am »

I am trying to mount a Samsung phone card with little luck. Some Unbuntu users have succeded but as of yet no luck for me. Vl-hot automatically picks up my Sony Ericsson but nothing on the Samsung. Vector does however know it is there.

The successfull users tried
Code: [Select]
mount /dev/sdaI get
Code: [Select]
mount: can't find /dev/sda in /etc/fstab or /etc/mtabIf I remove the comment from the below line in /etc/fstab could I mount as sda1
Code: [Select]
# example of a VFAT USB pendrive
#/dev/sda1  /mnt/pendrive vfat   fmask=111,dmask=0,noauto,user,quiet,shortname=mixed 0 0

I checked to see if device shows up
Code: [Select]
lsusb
Bus 003 Device 003: ID 04e8:663e Samsung Electronics Co., Ltd

double check to see if it is mounted
Code: [Select]
mount
/dev/hda2 on / type reiserfs (rw,noatime)
/dev/hda3 on /home type reiserfs (rw,noatime)
tmpfs on /dev/shm type tmpfs (rw)
usbfs on /proc/bus/usb type usbfs (rw,devmode=0666)
shm on /dev/shm type tmpfs (rw)
/dev/hda4 on /mnt/hda4 type reiserfs (rw,noatime)
I am assuming since the phone is connected via USB cable the usbfs is the phone. There are no other USB devices plugged in at the moment.


If I pull up the devices file from /proc/bus/usb I see this
Code: [Select]
T:  Bus=03 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
D:  Ver= 2.00 Cls=02(comm.) Sub=00 Prot=00 MxPS= 8 #Cfgs=  2
P:  Vendor=04e8 ProdID=663e Rev= 1.00
S:  Manufacturer=Samsung
S:  Product=SAMSUNG Mobile USB Modem
S:  SerialNumber=359322-01-095795
C:* #Ifs= 3 Cfg#= 1 Atr=c0 MxPwr=  2mA
I:* If#= 0 Alt= 0 #EPs= 0 Cls=02(comm.) Sub=08 Prot=00 Driver=(none)
I:* If#= 1 Alt= 0 #EPs= 1 Cls=02(comm.) Sub=02 Prot=01 Driver=cdc_acm
E:  Ad=81(I) Atr=03(Int.) MxPS=  16 Ivl=16ms
I:* If#= 2 Alt= 0 #EPs= 2 Cls=0a(data ) Sub=00 Prot=00 Driver=cdc_acm
E:  Ad=03(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms
C:  #Ifs= 1 Cfg#= 2 Atr=c0 MxPwr=  0mA
I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=02 Prot=50 Driver=
E:  Ad=03(O) Atr=02(Bulk) MxPS=  64 Ivl=0ms
E:  Ad=83(I) Atr=02(Bulk) MxPS=  64 Ivl=0ms

The file indicated by lsusb above /proc/bus/usb/003/003 is ureadable.
The phone is set for mass storage so I am looking for a block device. If the device is visible with the lsusb command should I not be able to mount it?
« Last Edit: June 15, 2009, 11:48:40 am by InTheWoods »
Logged

lagagnon

  • Global Moderator
  • Vectorian
  • *****
  • Posts: 1922
Re: Mount Samsung phone
« Reply #1 on: June 15, 2009, 11:15:14 am »

Remove the card, open a root terminal, type "tail -f /var/log/messages", insert the card and show us all the message lines you get after inserting the card....
Logged
"As people become more intelligent they care less for preachers and more for teachers". Robert G. Ingersoll

M0E-lnx

  • Administrator
  • Vectorian
  • *****
  • Posts: 3217
Re: Mount Samsung phone
« Reply #2 on: June 15, 2009, 11:30:37 am »

I'm assuming you're plugging it via a USB port.
Either what lagagnon said, or run tail -f /var/log/messages and then plug the usb cord in. Post the output.

Mine mounts my cool android powered G1 ;)... I use hal though.

InTheWoods

  • Vectorite
  • ***
  • Posts: 302
Re: Mount Samsung phone
« Reply #3 on: June 15, 2009, 11:48:14 am »

Code: [Select]
tail -f /var/log/messages
Jun 15 14:32:01 tecra2 vl-hot_mount: Showing desktop file vl-hot-sda1.desktop
Jun 15 14:32:01 tecra2 vl-hot_mount: Finishing vl-hot_mount...
Jun 15 14:32:11 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:33:34 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:33:51 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): starting (version 2.22.0), pid 4678 user 'lauren'
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): Resolved address "xml:readwrite:/home/lauren/.gconf" to a writable configuration source at position 1
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 15 14:34:25 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:34:41 tecra2 logger: ACPI group battery / action BAT1 is not defined

This was one of those days when you spend hours trying to find what turns out to be the simpilest of solutions.
You see my Sony Ericsson has to be turned off then plugged into the USB port for things to work properly.
All that was required to make the Samsung work was to turn it on prior to plugging it in to the USB port.
Doh!!!!

Thanks anyways.
Logged

DavidMorgan

  • Member
  • *
  • Posts: 1
Re: Mount Samsung phone <solved>
« Reply #4 on: August 08, 2010, 07:28:29 pm »



Code: [Select]
tail -f /var/log/messages
Jun 15 14:32:01 tecra2 vl-hot_mount: Showing desktop file vl-hot-sda1.desktop
Jun 15 14:32:01 tecra2 vl-hot_mount: Finishing vl-hot_mount...
Jun 15 14:32:11 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:33:34 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:33:51 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): starting (version 2.22.0), pid 4678 user 'lauren'
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): Resolved address "xml:readonly:/etc/gconf/gconf.xml.mandatory" to a read-only configuration source at position 0
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): Resolved address "xml:readwrite:/home/lauren/.gconf" to a writable configuration source at position 1
Jun 15 14:34:07 tecra2 gconfd (lauren-4678): Resolved address "xml:readonly:/etc/gconf/gconf.xml.defaults" to a read-only configuration source at position 2
Jun 15 14:34:25 tecra2 logger: ACPI group battery / action BAT1 is not defined
Jun 15 14:34:41 tecra2 logger: ACPI group battery / action BAT1 is not defined

This was one of those days when you spend hours trying to find what turns out to be the Business VOIP of solutions.
You see my Sony Ericsson has to be turned off then plugged into the USB port for things to work properly.
All that was required to make the Samsung work was to turn it on prior to plugging it in to the USB port.
Doh!!!!

Thanks anyways.

Was it turned off, then plugged in, or turned on then plugged in?

Edit:Nm, got it
« Last Edit: August 20, 2010, 02:44:15 pm by DavidMorgan »
Logged
Cheers,
David