VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Short HOWTO on installing Realtek audio driver on Acer laptop  (Read 4474 times)

sdboyd

  • Member
  • *
  • Posts: 38
    • Scott's Corner of the Web
Short HOWTO on installing Realtek audio driver on Acer laptop
« on: September 01, 2010, 09:48:19 pm »

If alsaconfig or alsamixer says you have hda-intel or HDA ATI SB or Realtek, this may work for you - even on other laptops.

I have an Acer laptop with VL 6.0 Std installed, and the audio only worked through the headphone jack after the install. I searched through the forum and found a post from Oct. 2009 that set me in the right direction - http://forum.vectorlinux.com/index.php?topic=10700.0

Go to the Realtek Website and download the driver, which is now up to version 5.15rc10. Click on "High Definition Audio Codecs (Software)" on this page: http://218.210.127.131/downloads/ - the Linux driver is near the bottom of the page, (after the Windows drivers, of course.)

After unpacking the driver file, open a terminal in the driver's directory, su to root ( or open a terminal as root), and run the install script. The install script compiles and installs new alsa drivers with support for the Realtek audio chip. Depending on the speed of your computer, it may take some time to do it's thing - be patient.

When given the choice of two different drivers to install, choose the first one: hda-intel  ATI Technologies Inc. SBx00 Azalia
Your choice may be somewhat different, but it should at least say "hda-intel". (The second choice ia a legacy driver.) The install script should play a test.wav file so you can hear if the install worked.

Considering how one can make many changes in Linux and not have to reboot, I didn't reboot after I ran the install script. I still only had sound through the headphone jack. I turn off my laptop most nights and during the day when I'm gone to work. So the next evening, when I booted up my laptop, I had sound through the speakers!

A month or so later, my VL install got hosed when I tried to upgrade the kernel. I had been wanting to install VL on a larger partition, so I went ahead and installed VL on the larger partition, and installed the Realtek drivers. This time I didn't have to re-boot to be able to hear sound through the speakers. So if the install doesn't look like it worked, try re-booting and see if that works for you.

Disclaimer: Your results are not guaranteed... your results may vary... your laptop may refuse to work - or it may crash...
« Last Edit: September 01, 2010, 10:23:23 pm by sdboyd »
Logged
Running VL 7.0 Std - Xfce4.8 on an Acer Aspire 5517 Laptop - Athlon64 X2 Dual Core L310 - 4GB RAM - 320GB HD