Please support VectorLinux!

Author Topic: S-Video out/external monitor help  (Read 8735 times)

fightingspirit

  • Member
  • *
  • Posts: 27
S-Video out/external monitor help
« on: August 04, 2008, 07:25:17 pm »
I'm getting an S-Video to RCA cable soon and I was wondering, is configuring my laptop to use the cable complicated? Actually, in general, is configuring my laptop to use an external monitor complicated? Would I have to edit xconf or would I just have to plug in the cable and boot my system on? Because if I remember correctly, on Windows, I just had to connect the external monitor and go to the system settings and enable the second monitor and position it, as well as set its resolution. I hope its that easy...

Well anyway, any help would be appreciated. Thanks!

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: S-Video out/external monitor help
« Reply #1 on: August 04, 2008, 07:32:11 pm »
I did it once for a tv (with s-video) and it was a matter of editing xorg.conf.
It wasn't very easy... I took most of the tips from the gentoo wiki, and then trial and error.

If you have an Nvidia card, perhaps some of the functions in the "Nvidia X server settings" can help.

fightingspirit

  • Member
  • *
  • Posts: 27
Re: S-Video out/external monitor help
« Reply #2 on: August 04, 2008, 07:37:09 pm »
and thats the problem, i have an ati graphics card...
anyway, I tried using an external monitor via my VGA slot, and it worked fine through boot, but when booting up my desktop, the monitor went blank and my laptop screen turned back on. I;m guessing its because of the resolution I use, since my PC monitor uses a much smaller res. Is using a VGA slot similar to using S-Video at all?

Also, I'll look into that Gentoo wiki, but a link would be nice too :p

never mind, is this it?
http://gentoo-wiki.com/HOWTO_TV-Out
« Last Edit: August 04, 2008, 07:42:28 pm by fightingspirit »

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: S-Video out/external monitor help
« Reply #3 on: August 04, 2008, 07:49:54 pm »
That link should be it.
I think I used this one: http://gentoo-wiki.com/HOWTO_Separate_x-screens_on_Monitor_and_TV
But it seems to be only for nvidia cards (and I wanted two different x-screens).

If it came up when booting that's not bad at all...  it might only require some tinkering in xorg.conf.
Wish I could help more.


fightingspirit

  • Member
  • *
  • Posts: 27
Re: S-Video out/external monitor help
« Reply #4 on: August 05, 2008, 07:21:33 pm »
That link should be it.
I think I used this one: http://gentoo-wiki.com/HOWTO_Separate_x-screens_on_Monitor_and_TV
But it seems to be only for nvidia cards (and I wanted two different x-screens).

If it came up when booting that's not bad at all...  it might only require some tinkering in xorg.conf.
Wish I could help more.



No problem, that link was a lot of help  ;D

fightingspirit

  • Member
  • *
  • Posts: 27
Re: S-Video out/external monitor help
« Reply #5 on: August 07, 2008, 06:19:15 pm »
sorry for the double post, but I got it to work! I'm so f'n happy right now... It was way easier than I thought it would be; I didn't even have to touch my xconf.org file...

So here's what I did (all in terminal):
First off, installed xvattr, then in the terminal:

$ xrandr --output S-video --set load_detection 1
$ xrandr --addmode S-video 800x600
$ xrandr --output S-video --mode 800x600
And to play videos on your output screen (the original monitor won't see the video anymore):
$ xvattr -a XV_CRTC -v 1

And to return everything to normal:
Turn off the s-video output:
$xvattr -a XV_CRTC -v 0

Bring video output back to default monitor:
$xrandr --output S-video --off

wcs

  • Packager
  • Vectorian
  • ****
  • Posts: 1144
Re: S-Video out/external monitor help
« Reply #6 on: August 08, 2008, 02:18:30 am »
Great! Very nice.
I wonder if that works with different video cards.

I'll give it a try.

beaverco

  • Member
  • *
  • Posts: 2
Re: S-Video out/external monitor help
« Reply #7 on: October 17, 2010, 07:21:06 pm »
Hello,

I got an old laptop and installed vector linux 6 on it so i can use it for watching movies;
i tried to connect it to the tv using an s-video cable but i cant make it work...
i tried the above using xvattr, but i always get an error message after the first command.
And the links to the gentoo howto don't work...

can anyone explain to me how i can get my svideo out to work?
Thanks


Jan

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4076
Re: S-Video out/external monitor help
« Reply #8 on: October 18, 2010, 05:14:18 am »
@beaverco: Please supply more information about your hardware and VL version, plus what error message you get.

beaverco

  • Member
  • *
  • Posts: 2
Re: S-Video out/external monitor help
« Reply #9 on: October 18, 2010, 06:02:42 am »
Hi, I am using VL 6.0 light on an old Fujitsu Siemens C 6175 (Lifebook).
I am not 100% sure about the graphics card but I think it is a Rage Mobility M.

I installed xvattr, so after running
Code: [Select]
xrandr --output S-video --set load_detection 1 as su i got the following error:

X Error of failed request: 180
   Major opcode of failed request: 155 (RANDR)
   Minor opcode of failed request: 15 ()
   Serial number of failed request: 14
   Current serial number in output stream: 14

Thanks

Jan