Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: No WICD Network Status Icon in VL6.0 Light. [Solved]  (Read 3377 times)


  • Member
  • *
  • Posts: 14
No WICD Network Status Icon in VL6.0 Light. [Solved]
« on: October 14, 2010, 10:48:10 pm »

I have VL6.0 Light installed on an old IBM Aptiva AMD K6 266Mhz w/256Mb memory. Everything works OK, except that there's no WICD network status icon in the panel. I ran "wicd-client" from a terminal session, and the status icon displayed in the panel OK, but the terminal session never came back to an input prompt. When I closed the terminal window, the icon disappeared from the panel. Later after rebooting I added the following lines to startup in the ~/.icewm directory:

# Start WICD network status icon.

After adding those lines, I logged out and back in, and the status icon displayed. Great!! Then I shut the PC completely down and did a cold boot. This time, after I logged in, the status icon didn't display. Logging out and back in resulted in the same thing, nothing.  ???

My question is: What should I do (Step by step) to get the WICD network status icon to automatically display in the panel?
« Last Edit: October 16, 2010, 02:38:12 am by vlinco »


  • Administrator
  • Vectorian
  • *****
  • Posts: 4455
Re: No WICD Network Status Icon in VL6.0 Light
« Reply #1 on: October 15, 2010, 04:47:58 am »

There are two parts to wicd. First, you need to start the wicd service by running:
Code: [Select]
vasm > super > service > srvset > 4 Graphical user interface desktop > [select the entry for wicd] > ok > exit all the way out
Next, change the line in your startup file to launch the client:
Code: [Select]
wicd-gtk &


  • Member
  • *
  • Posts: 14
[Solved] No WICD Network Status Icon in VL6.0 Light.
« Reply #2 on: October 15, 2010, 06:33:44 am »

First of all, thank you very much for the quick response.

Did exactly as you instructed, shut down completely, and restarted the PC. Still no WICD network status icon.

Tried changing "wicd-gtk &" that I added to ~/.icewm/startup to "wicd-client &". After a complete restart, it worked great!

I have the WICD network status icon now.

Thanks for the help.