Author Topic: Disabling Hard Drive DMA  (Read 8155 times)


  • Member
  • *
  • Posts: 1
Disabling Hard Drive DMA
« on: October 20, 2010, 03:06:51 pm »
Hello I'm using an XVME661 at work to test our products however this system is having problems with the harddrive dma so when you boot the system after lilo the system will freeze for like two minutes until the os loading continues, I've tried another linux vesions and is always the same it seams a timeout when the kernel is trying to enable dma for my ide. DMA and ULTRADMA on the bios is disabled because if I enable it the system wouldn't ever reach the lilo screen. I know it's probably a faulty bios but somehow windows XP is not affected by it(boots normally). I also included the noacpi command on lilo.


  • Vectorite
  • ***
  • Posts: 152
Re: Disabling Hard Drive DMA
« Reply #1 on: April 04, 2011, 05:54:55 pm »
Have you tried passing the  "ide=nodma" parameter to the kernel at bootup?

To do this manually, you can hit tab at the boot window, then manually enter the name of the kernel you want to use, then at the end, put the parameter like this:   
linux-kernal-name ide=nodma

This should start the kernel with dma turned off altogether.

If this works, you can also put it into an 'append' line in /etc/lilo.conf for the kernal images you use so you don't have to do any manual steps.   (Don't forget to run lilo after editing to actually incorporate any changes made in the config file!)

See Documentation/ide.txt in the kernel source tree for more info on what you can do.
=^_^=  Tigerwolf

Running: Vector Linux 5.8 Standard   12-16-2006