April 18, 2015, 12:20:21 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
Author Topic: mount nfs share at boot problem [solved]  (Read 4162 times)
Posts: 55

« on: November 01, 2010, 12:09:26 am »


I am trying to mount nfs share at boot with /etc/fstab, vector 6 is the client, ubuntu server is the server. This entry in fstab failed at boot:  /home/nfsshare nfs defaults 0 0

I can mount the share from the command line using sudo but fstab is failing for some reason.

Thanks for any advice,


Solution: As advised just added 'mount -a -t nfs' to /etc/rc.d/rc.local and nfs share came up. Anyone know how to delay fstab nfs mounting until the network is up, so you don't get the network filesytems failed message at boot?
« Last Edit: November 03, 2010, 10:38:58 pm by davidlondonuk » Logged
Posts: 4070

« Reply #1 on: November 01, 2010, 09:50:51 am »

It is probably because fstab is processed before your network is ready.
Try adding these lines to /etc/rc.d/rc.local:
sleep 3
mount -a -t nfs
The idea is to give the system time to bring up the network connection.
You may not need the sleep entry, you can try without it first.
Or you may need to increase the delay. Some quick experimentation should lead you to the optimal settings.
Posts: 55

« Reply #2 on: November 01, 2010, 10:58:32 am »

Thanks night I will give that a wirl.
Pages: [1]
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!