Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: mount nfs share at boot problem [solved]  (Read 6144 times)


  • Member
  • *
  • Posts: 55
mount nfs share at boot problem [solved]
« on: November 01, 2010, 01:09:26 am »


I am trying to mount nfs share at boot with /etc/fstab, vector 6 is the client, ubuntu server is the server. This entry in fstab failed at boot:  /home/nfsshare nfs defaults 0 0

I can mount the share from the command line using sudo but fstab is failing for some reason.

Thanks for any advice,


Solution: As advised just added 'mount -a -t nfs' to /etc/rc.d/rc.local and nfs share came up. Anyone know how to delay fstab nfs mounting until the network is up, so you don't get the network filesytems failed message at boot?
« Last Edit: November 03, 2010, 11:38:58 pm by davidlondonuk »


  • Administrator
  • Vectorian
  • *****
  • Posts: 4455
Re: mount nfs share at boot problem
« Reply #1 on: November 01, 2010, 10:50:51 am »

It is probably because fstab is processed before your network is ready.
Try adding these lines to /etc/rc.d/rc.local:
Code: [Select]
sleep 3
mount -a -t nfs
The idea is to give the system time to bring up the network connection.
You may not need the sleep entry, you can try without it first.
Or you may need to increase the delay. Some quick experimentation should lead you to the optimal settings.


  • Member
  • *
  • Posts: 55
Re: mount nfs share at boot problem
« Reply #2 on: November 01, 2010, 11:58:32 am »

Thanks night I will give that a wirl.