VectorLinux
April 24, 2014, 12:12:30 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: vlc plays sound but no video [solved]  (Read 10037 times)
davidlondonuk
Member
*
Posts: 55


« on: November 01, 2010, 01:06:35 am »

Hi,

I tried vlc with an avi (divx) file and it plays sound but no video-my setup is after a new install.

Thanks for any help,

David

Solution: simple really-just went to preferences/video and on output video just selected X11 video, it was set to a default option-works fine now
« Last Edit: November 02, 2010, 12:20:12 am by davidlondonuk » Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: November 01, 2010, 06:33:47 am »

VLC uses FFMPEG.  If you want to see if the problem rests with FFMPEG you can just play the video directly with ffmpeg in the terminal with this command...
ffplay ./nameoffile.avi

If that is the source of the trouble try upgrading FFMPEG from gslapt.

MPlayer uses Gstreamer instead of FFMPEG.  If you find you are playing that particular video with MPlayer than maybe you just have a codec/container combination that VLC just does not agree with.  Usually, it's the other way around.  I have more occasions when MPlayer does not play a file but VLC does, but that's why it is nice to have both.
 
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
davidlondonuk
Member
*
Posts: 55


« Reply #2 on: November 01, 2010, 10:52:23 am »

Thanks stretched, the avi files play fine using ffplay from the command line, the same with mplayer from command line. If I try the files in vlc it's sound only and no video.

I checked in gslapt, I am using the svn ffmpeg from the gsb repo, there is also a gst-ffmpeg package that is not installed?

Thanks,

David
« Last Edit: November 01, 2010, 11:03:27 am by davidlondonuk » Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #3 on: November 02, 2010, 05:39:41 am »

You don't mention your hardware, but vlc's default video output setting works for me on Intel graphics and, possibly, on ATI/AMD cards with the open source xorg driver. It doesn't work at all on ATI/AMD with the propietary driver. In that case, pick the opengl setting which is hardware accelerated with this driver, not X11, which is slow. Normally, and AFAIK, the default picks xvideo, which is accelerated on Intel and others. I have no idea regarding Nvidia hardware, so someone else would have to chip in...

Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!