VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: wicd shows connect_ browsers don't work[SOLVED]  (Read 4072 times)

Pet3M0ss

  • Member
  • *
  • Posts: 22
wicd shows connect_ browsers don't work[SOLVED]
« on: November 16, 2010, 08:14:08 pm »

Bought and installed Vector Deluxe because a Vector KDE Classic (live) worked so well connecting the wireless on this Dell laptop.

Have yet to get the wireless to work. Wicd shows a connection (percentage usage and IP address showing), but none of the browsers can access the net. The VLwifi locates my wlan0 but never finds any hotspot. Strange how wicd finds them, and VLwifi cannot.

Ifconfig and iwconfig show my wlan0 card. I changed the wireless interface.conf module from "ndiswrapper" to "b44" and "b43legacy" (my wireless chip is BCM4306. Wicd seems to connect at boot time, but still no real connection from my browsers to Google.

Since the live CD worked on the wifi, I am pretty certain Vector Deluxe should do the same, right?? Where would I look to correctly configure my wireless??
« Last Edit: November 20, 2010, 07:46:00 pm by Pet3M0ss »
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4133
Re: wicd shows connect_ browsers don't work
« Reply #1 on: November 17, 2010, 06:31:55 am »

KDE Classic Live came after Deluxe, and some packages were updated in the interim.

If you have access to a wired connection.. if it works, you could try upgrading the system and see if it makes a difference.
Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: wicd shows connect_ browsers don't work
« Reply #2 on: November 17, 2010, 09:35:41 am »

thanks nightflier.

I'm tweaking my laptop while killing evenings in a hotel, so it may be next week before I get to my home router.

I did run something in VASM that had me deleting some improper scripts.

Will try the upgrades before I go any further.
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: wicd shows connect_ browsers don't work
« Reply #3 on: November 17, 2010, 05:19:37 pm »

Wicd shows a connection (percentage usage and IP address showing), but none of the browsers can access the net. The VLwifi locates my wlan0 but never finds any hotspot. Strange how wicd finds them, and VLwifi cannot.

Ifconfig and iwconfig show my wlan0 card. I changed the wireless interface.conf module from "ndiswrapper" to "b44" and "b43legacy" (my wireless chip is BCM4306. Wicd seems to connect at boot time, but still no real connection from my browsers to Google.

This sounds very much like a wireless issue I have with VectorLinux 6 Light. It is configured correctly with wicd and the wireless card loads and is ready to go at startup. I can mount other computers on my nfs network then and transfer files between them. I cannot, however, connect to the Internet. Nor can I ping an Internet address. When the IceWM desktop loads, wicd shows a connection to my wireless router at 100% and the correct IP address, which I assigned manually as I use fixed IP addresses. You'd think I could connect to the Net when I start my browser, but I can't.

I have to disconnect with wicd and then click on Connect and wait for the connection to be established. Now I can get to Web sites with my browsers and there are no problems whatever with the wireless connection from then on.

I tried *everything* to get a wireless connection that was ready for the Internet when VL6 started, all to no avail. I finally decided I had to do it the way the connection wanted it, so as soon as my IceWM desktop comes up I use wicd to disconnect from my wireless connection and then use wicd to connect again. This is quick and easy and works every time, but I'd prefer if it could connect to the Internet automatically.

This may not apply to your problem at all. You are using a Broadcom driver, I'm using a Ralink. Broadcom used to need a kernel patch; I don't think that's true with the most recent VL SOHO releases. But if you haven't already tried this, see what happens.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

sledgehammer

  • Vectorian
  • ****
  • Posts: 1472
Re: wicd shows connect_ browsers don't work
« Reply #4 on: November 17, 2010, 09:32:20 pm »

I don't know if this has anything to do with the problem or not, but I know on my system (VL6.0 standard) I use wicd esclusively.  It connects but I can't get on the internet until I, from root, load firestarter and then in firestarter preferences -> Network Settings, click enable "wireless," or, if connected to the wire, enable "ethernet."  I don't really understand firewalls, and may have disabled the stock firewall in the Vector Control Center.
Logged
VL7.0 xfce4 Samsung RF511

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4133
Re: wicd shows connect_ browsers don't work
« Reply #5 on: November 18, 2010, 07:44:26 am »

as soon as my IceWM desktop comes up I use wicd to disconnect from my wireless connection and then use wicd to connect again

Sounds like a reasonable workaround, which could be automated. Granny, would you be up for testing some simple bash scripting for this?
Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: wicd shows connect_ browsers don't work
« Reply #6 on: November 18, 2010, 11:49:28 am »

Thanks for the tips. I managed to get my lappy eth0 connected in an office where I am temp-ing. All software should be upgraded. Will try to make the wlan0 connection this evening when I get back to my hotel.

You've given me hope!
Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: wicd shows connect_ browsers don't work
« Reply #7 on: November 18, 2010, 09:07:29 pm »

AARRRRGH!  :'(
I was able to connect after totally exiting wicd, then calling it up off the menu again. Did some surfing, got a drink of water before reporting back to this forum, and I was disconnected. Figured it was just the wifi server signal had a hiccup and dumped me, but I was never able to reconnect!! Rebooted, dropped to init 2 and used vasm to try and reconfigure to the defaults, etc. No Go.

Firestarter is evidently not configured in Vector Deluxe (at least that's what I get when I try to start it from the menu).

Iwlist with scanning shows a lot of wifi spots (none besides this hotel are unencrypted). Wicd shows a connection but still no connection from the browsers to the net.

Maybe the hotel signal isn't strong enough (60-70%).

After reading another post, is it possible I need to work around an ipmask thing?? I work as root to try and bypass some permissions issues.

Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: wicd shows connect_ browsers don't work
« Reply #8 on: November 19, 2010, 09:47:47 am »

 :D booted up this morning, and the wifi connected like it was supposed to!! ??? Hotel server may be the culprit for cutting me off.

Will see how wifi works when I get home and can actually monitor my router.

Thanks for the help
Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: wicd shows connect_ browsers don't work[SOLVED]
« Reply #9 on: November 19, 2010, 04:10:21 pm »

 ;D I got the wireless up successfully and am posting from my hotel room

My method was to disconnect the boot up wicd connection, open a root terminal to ifconfig etho down, then dhcpcd wlan0, up the wicd from the gui panel, reconnect, and here I am.

« Last Edit: November 20, 2010, 07:44:35 pm by Pet3M0ss »
Logged