Author Topic: boot stalled at kernel panic after updating  (Read 4499 times)


  • Vectorite
  • ***
  • Posts: 469
boot stalled at kernel panic after updating
« on: November 24, 2010, 08:40:30 pm »
because vl6sohofinal kernel  doesn't support  rt2500usb wireless wpa mode,
I installed the light version of kernel- and its modules
from VL7-alpha-2 to my sharp mebuis PC-GP10-BE laptop  ,but it dowsn't work  and stalled at booting"kernel panic, can't load root file system ,etc"
then i went slackware mirror downloaded the latest kernel and its module and installed, still can't boot  stalled at "kernel panic, can't load root file system ,etc"
at /etc/lilo.conf, adding root=/dev/sdax also didn't work...
also tried mkinitrd command building a new initrd.gz file, stilll can't boot into...
while in this forum all the others' feedback for the latest kernel 're positive, functional, worked flawlessly...
for the old hardware any other latest kernel  package i can try?
or any command fix available


  • Packager
  • Vectorian
  • ****
  • Posts: 568
  • NewComer
Re: boot stalled at kernel panic after updating
« Reply #1 on: December 17, 2010, 01:56:43 pm »
If you want a new kernel you might want to consider compiling your own - here's a great explanation on how to do it.

I had a similar problem - I needed rt2860sta module not included with the vl6.0 kernel, so I compiled it myself and now my wireless is up and running.
VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!