VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Can't shut down or restart? [solved]  (Read 540 times)

RonB

  • Vectorite
  • ***
  • Posts: 120
Can't shut down or restart? [solved]
« on: December 10, 2010, 03:34:50 am »

I've never had this happen before. Tried to shut down VectorLinux (Standard Deluxe 6) and I got a request for a password? So I tried putting in my user password and it said it was wrong (I guess it wanted the root password). Now the "Restart" and "Shut Down" options are grayed out and I can only log off and shut down from the start up screen. (I've rebooted and it's still doing it.) What in the world did I do? And how did I do it? And how do I fix it?

Thanks for any pointers.

It's like magic. Have no clue, can't figure out the problem at all -- post here and the answer comes immediately. Weird. I had left myself out of the "users" group when I fixed my group problem. When I installed jpilot earlier today, I remembered I had to add myself to the "uucp" group to get my palm to sync to jpilot. Unfortunately I screwed up by using:

usermod -G uucp <user>

I found out that the usermod with the "-G" option clears out everything and only puts you in exactly what groups you specify. So I had to build a new user to see what groups new users are normally put into. Somehow I missed "users." Why I didn't see the effect until hours later, I don't know. I guess I hadn't shut down the computer. Or maybe it had something to do with installing VirtualBox. At any rate, I think I've got it now.

A quick question. Is there a way to edit users in the GUI? -- something I could install, so I won't do stupid things like this? Or, alternately, is "usermod -G <groups> <user>" the best way to do this? Is there an option that just adds one group to what's already there?


It looks like there used to be an "--append" or "-a" option in usermod, but it no longer has any effect and doesn't appear in the man page. Odd, this would be nice to have back.

Ack! All the problems could have been non-existent if I had only used the right command. What I needed to do was type:

gpasswd -a username uucp

I'm living proof that a little knowledge is a dangerous thing.


« Last Edit: December 13, 2010, 01:17:42 pm by RonB »
Logged
RonB
Registered Linux User #498581
Vector Linux Deluxe 6.0 -- Optiplex GX270