VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Can't get video4fuze to run on VL7 a4  (Read 2232 times)

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Can't get video4fuze to run on VL7 a4
« on: December 19, 2010, 01:38:19 pm »

VL version is VL7 alpha 4

I have a great need to get video4fuze working. I need it in order to turn videos into a format my Sansa Fuze will recognize. Sansa has a Windows only media converter but I can't install it--a problem reported by many users. video4fuze is supposed to do the same job, and remarkably, it is supposed to work in Linux. It runs with python. I downloaded the source and it is ready to work once you expand the tar.gz file and confirm that you have the needed dependencies. I was lacking fuzemux but I downloaded the source and did a quick and easy compile with configure-make-make install.

I needed PyQt, which was not in the VL7 repo, so I downloaded it from VL6 (/testing, I think). To start video4fuze, you type
python video4fuze.pyw
at the prompt in the video4fuze directory. When I do that, I get this:
Code: [Select]
Traceback (most recent call last):
  File "video4fuze.pyw", line 23, in <module>
    from PyQt4.QtGui import QApplication
ImportError: No module named PyQt4.QtGui

What now? I've tried symlinks in /usr/lib to usr/lib/python2.5/site-packages/PyQt4/QtGui.so and done ldconfig, but I still get the same error message.
--GrannyGeek
« Last Edit: December 19, 2010, 09:43:18 pm by GrannyGeek »
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Can't get video4fuze to run
« Reply #1 on: December 19, 2010, 05:05:14 pm »

I decided to see if I could get video4fuze to run on my VL6 Light laptop. Success! PyQT was already there. I easily compiled fuzemux. It's small and compiles very quickly. I had to install qt 4.5 from the vl6 /testing repo. I checked messages here first to make sure I wouldn't destroy my system by installing qt4.5.

After I got the dependencies in place, I ran video4fuze successfully and it has just finished converting a movie. I haven't yet moved it to my Sansa Fuze, so I don't know whether I got the results I wanted. Fingers crossed!

I would still like to get video4fuze working on my VL7 a4 machine.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Can't get video4fuze to run
« Reply #2 on: December 19, 2010, 09:41:38 pm »

The converted movie was perfect! I've started watching it on my Sansa Fuze. I also successfully converted and loaded some photos. I had previously loaded MP3 music files. They don't need conversion.

The movie is Reefer Madness, a cult classic. It's hilarious in the manner of movies like Island Claws and Plan 9 from Outer Space. I love bad movies.

Since I now have a video4fuze that works, I think I'll abandon more efforts to get it working on VL7 unless somebody comes up with a way I can fix the python and PyQt problems. Maybe things will be better in the next VL7 release.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Can't get video4fuze to run on VL7 a4
« Reply #3 on: December 21, 2010, 07:57:27 am »

The Multimedia Bonus disk for VL7.0 now includes 'video4fuze'.  You can find the full list of applications here....
MMBD VLstd7.0 full edition.

Added this yesterday, just to entice you into trying the disk Granny.  Working on the 6.0Soho version today.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Can't get video4fuze to run on VL7 a4
« Reply #4 on: December 21, 2010, 05:59:23 pm »

I planned to order the MMB disk in the next few days, but I'll speed that up.

Thanks for adding video4fuze.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Can't get video4fuze to run on VL7 a4
« Reply #5 on: December 21, 2010, 06:12:01 pm »

I planned to order the MMB disk in the next few days, but I'll speed that up.

Thanks for adding video4fuze.
--GrannyGeek

Thanks for mentioning video4fuze, it was a natural fit for the disk, I've added it both to the vl70 disk and the vl60soho disk.  I also added gtkpod to vl70 for the same reasons.
 
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee