Please login or register.

Login with username, password and session length
Advanced search  


Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: Installing Moonlight on VL 6.0 Light  (Read 1624 times)


  • Member
  • *
  • Posts: 74
Installing Moonlight on VL 6.0 Light
« on: February 22, 2011, 08:30:47 am »

I'd like to install Moonlight (an open source implementation of Microsoft Silverlight, for Linux).
In addition I'd prefer not to install the Microsoft Media Pack codecs, but the opensource ones.
Any suggestions?
Best Regards



  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Installing Moonlight on VL 6.0 Light
« Reply #1 on: February 22, 2011, 10:37:30 am »

For Moonlight, the way I've installed it is to do it through Firefox. Open Firefox, go to and click on Download. It will install the Moonlight add-on and offer to restart Firefox. Click on Restart and it will restart automatically. That should do it. I don't know if it will work without the Microsoft Media Pack codecs.

However, I just installed Moonlight in Firefox with VL7 beta 1 and it crashes Firefox. I don't know if this is due to beta1 or a general problem with Moonlight. I'll check it out on my VL6 Light computer later and see what happens. This is  what I get when I start Firefox from the command line:
Code: [Select]
[code]me:$ firefox
Moonlight: Attempting to load libmoonloaderxpi
debug_get_option: GALLIUM_DRIVER = softpipe
couldn't open, software DXTn compression/decompression unavailable
Moonlight: no audio capture service available
Moonlight: Installing signal handlers for crash reporting.
Moonlight: Enabling MONO_DEBUG=keep-delegates,reverse-pinvoke-exceptions and MOONLIGHT_ENABLE_CONSOLE=1
Moonlight: Loaded mscodecs from: /home/me/.mozilla/plugins/moonlight/
Using the ff3 bridge
Moonlight: Plugin AppDomain Creation: OK
Moonlight: URL =
Moonlight: URL =

(firefox:3689): Moonlight-WARNING **: Insufficient OpenGL version: 1.3 Mesa 7.10.1-devel
debug_get_bool_option: GALLIUM_NOSSE = FALSE
debug_get_bool_option: GALLIUM_DUMP_FS = FALSE
debug_get_bool_option: SOFTPIPE_DUMP_GS = FALSE
debug_get_bool_option: DRAW_FSE = FALSE
debug_get_bool_option: DRAW_NO_FSE = FALSE
debug_get_bool_option: GALLIUM_DUMP_VS = FALSE
debug_get_bool_option: SP_NO_RAST = FALSE
debug_get_bool_option: GALLIUM_NOSSE = FALSE
Using native xaml parser.
trying to load: /System.Windows;component/themes/generic.xaml
trying to load: /System.Windows.Controls;component/themes/generic.xaml
Moonlight: ErrorEventArgs created with message: 'downloader failed'
Moonlight: ErrorEventArgs created with message: 'downloader failed'

Unhandled Exception: System.ExecutionEngineException: SIGILL

I don't understand any of that.
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller