VectorLinux
October 24, 2014, 06:33:20 pm *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 20110114 sdl-1.2.14 [VL7.0]  (Read 1431 times)
toothandnail
Moderator
Vectorian
*****
Posts: 2527


« on: January 14, 2011, 10:26:31 am »

budulay has built a new Sdl package for VectorLinux 7.0.
   
      
   
Code:
sdl: sdl (Simple DirectMedia Layer library)
sdl: This is the Simple DirectMedia Layer, a generic API that provides low
sdl: level access to audio, keyboard, mouse, joystick, 3D hardware via
sdl: OpenGL, and 2D framebuffer across multiple platforms.
sdl: SDL links against alsa-lib, arts, audiofile, esound, and the X11
sdl: libraries.  Make sure all of these are installed if you're planning to
sdl: use SDL (a full installation will cover all of the prerequisites).
sdl: License: GPL
sdl: Authors: Sam Lantinga, see CREDITS
sdl: Website: http://www.libsdl.org/index.php
   
   After testing this package please stop back here and let us know how it works for you.
   
Logged
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #1 on: January 14, 2011, 02:35:09 pm »

SDL 1.2.14 is already part of vl7.0.   It's just that it is all capitalized.
/var/log/packages/SDL-1.2.14-i586-2vl70
I'm wondering if having a second differently named package will create a problem. lf someone uses slapt-get to remove a package that also removes the sdl/SDL package as a dependency. Then installing anything that was built against the uppercase SDL package fails because SDL is not really there but it still shows up in /var/log/packages/.
« Last Edit: January 14, 2011, 02:55:05 pm by stretchedthin » Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #2 on: January 14, 2011, 02:46:11 pm »

What version of VL7?

I remember needing it for something on Alpha 4.6...
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
stretchedthin
Administrator
Vectorian
*****
Posts: 3780


WWW
« Reply #3 on: January 14, 2011, 03:07:18 pm »

You may have needed it because the SlackBuild you were working off of had a premade slack-required call for 'sdl' lowercase.  I ran into this as well, since I think 'sdl' lowercase is a very common way of installing sdl on slackware systems.  SDL uppercase is how the package itself is named when you download the source.

Anyway, I bet if you...
ls /var/log/packages/SDL*
and
ls /var/log/packages/sdl*
you will find both.

I'm not an expert on slapt-get dependencies but my worry is that when one is removed either by removepkg or by slapt-get the other one will remain in name only in /var/log/packages/.  This would then cause slapt-get to think it is there when it is not.  Maybe someone more experienced can verify.
Logged

Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #4 on: January 14, 2011, 03:23:51 pm »

Maybe that's what it was... Roll Eyes

I checked and there is a SDL-1.2.14 package in VL7, so I guess to avoid confusion this one should be removed.

EDIT:
I just remembered. I needed sdl to install wxGTK(which in turn I needed to build filezilla) that was already in the repo but had 2 unmet dependencies - pixman and sdl.
I just installed wxGTK on A4.9 with --no-dep(since SDL-1.2.14 is already installed) and then installed filezilla and everything seems to work. So it seems it's a problem with wxGTK package.

I'll post this in the VL7 A4 feedback thread.
« Last Edit: January 14, 2011, 03:51:42 pm by budulay » Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
budulay
Packager
Vectorian
****
Posts: 568


NewComer


« Reply #5 on: January 14, 2011, 03:51:11 pm »

On the other hand, I think I'll just rebuild wxGTK this weekend Grin
Logged

VL6.0-Light@MSI MS-1652(AMD TurionX2 ZM-84 2300 MHZ, 4 GB RAM, 250 GB HDD, Nvidia GForce 9600M GT, GIGABYTE AirCruiser N300)
Registered Linux user #473602
SlackBuild Repository for VL7.Not much but it's a start. Join in!
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!