VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: [Fixed] Messed up my LiLo menu screen  (Read 3186 times)

Pet3M0ss

  • Member
  • *
  • Posts: 22
[Fixed] Messed up my LiLo menu screen
« on: January 16, 2011, 06:19:53 am »

Am using a newly purchased VL 6. Had some issues installing to a laptop (the touchpad was too sensitive??), so I used the alternative text-based method.

I ended up with a VL LiLo menu screen, but it just says "linux" instead of Vector Linux. Thinking I could improve on that, I used the VASM to reload LiLo. Now, I have a Slackware boot menu!!

Could someone give me a path where I could reset LiLo. I would like it to proclaim Vector Linux as a choice as well as my WinXP partition.

Maybe I should just install GRUB and be done with it.
« Last Edit: January 19, 2011, 07:44:50 pm by Pet3M0ss »
Logged

stretchedthin

  • Administrator
  • Vectorian
  • *****
  • Posts: 3780
    • Opensourcebistro.com
Re: Help! Messed up my LiLo menu screen
« Reply #1 on: January 16, 2011, 07:43:54 am »

I'm remembering two lilo config utilities. One called liloconf which set's up lilo the slackware way, the other called vliloconf, which of course does it the Vectorway.  Try running vliloconf as root and let us know where that takes you.
Logged
Vectorlinux screencasts and  tutorials can be found at....
http://www.opensourcebistro.com/blog1
http://www.youtube.com/user/vid4ken?feature=mhee

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: Help! Messed up my LiLo menu screen
« Reply #2 on: January 18, 2011, 06:46:44 pm »

Thanks stretchedthin, the vliloconf command reset the boot menu to the one I had after a text install (choices are "linux,Win, linux-tui, and linux-gui").

I went in to /etc/lilo.conf and tried changing the "linux" to "Vector Linux" but nothing changed upon reboot. Any idea where I could change the text and dress up the menu properly??
Logged

GrannyGeek

  • Packager
  • Vectorian
  • ****
  • Posts: 2567
Re: Help! Messed up my LiLo menu screen
« Reply #3 on: January 18, 2011, 06:52:42 pm »

Thanks stretchedthin, the vliloconf command reset the boot menu to the one I had after a text install (choices are "linux,Win, linux-tui, and linux-gui").

I went in to /etc/lilo.conf and tried changing the "linux" to "Vector Linux" but nothing changed upon reboot. Any idea where I could change the text and dress up the menu properly??

Did you run
lilo
as root as a prompt after you made changes to /etc/liloconf? I'm also assuming you edited liloconf as root.
--GrannyGeek
Logged
Registered Linux User #397786

Happily running VL 7 Gold on  a Sempron LE-1300 desktop (2.3 GHz), 4 G RAM,  GeForce 6150 SE onboard graphics and on an HP Pavilion dv7 i7, 6 gigs, Intel 2nd Generation Integrated Graphics Controller

newt

  • Vectorian
  • ****
  • Posts: 1132
Re: Help! Messed up my LiLo menu screen
« Reply #4 on: January 18, 2011, 07:28:40 pm »

You'll need to chose labels without any spaces ('VectorLinux' or 'Vector_Linux' are good; 'Vector Linux' is not).  When you change a 'label' for the primary boot option, you'll need to make sure your 'default' choice (towards the top of lilo.conf) matches.  Last, as granny mentioned, you'll need to edit lilo.conf as root and run 'lilo -v' when you're done making the changes (also as root). If the output from the command 'lilo -v' reports any errors then you should not reboot until those are fixed - warnings are (almost always) okay.
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1332
Re: Help! Messed up my LiLo menu screen
« Reply #5 on: January 18, 2011, 10:13:19 pm »

In addition to the -v flag add the -t flag for test. lilo -t -v. Then when test is OK
run lilo w/o -t. I sometime forget this. ;)
Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: Help! Messed up my LiLo menu screen
« Reply #6 on: January 19, 2011, 06:07:40 am »

OK, my Vector Linux label attempt caused the lilo -t -v command to show something like "extraneous Linux", so your suggestions were on target (both how to find and how to correct).

Now it looks real nice at boot, but lilo then loads into a text-based VL sign in!! The Slackware keeps reclaiming it's old territory.
Logged

nightflier

  • Administrator
  • Vectorian
  • *****
  • Posts: 4105
Re: Help! Messed up my LiLo menu screen
« Reply #7 on: January 19, 2011, 09:01:12 am »

To get GUI login (runlevel 4), you can add a "4" to the options. Here is a sample section for /etc/lilo.conf:
Code: [Select]
# Partition 2: Linux GUI mode
image = /boot/vmlinuz
    root = /dev/sda1
    label = linux-gui
    append = "4  "
    read-only

Of course, make sure that the root path is correct for your system.
Logged

Pet3M0ss

  • Member
  • *
  • Posts: 22
Re: Help! Messed up my LiLo menu screen
« Reply #8 on: January 19, 2011, 07:43:59 pm »

Thanks all, I've got it together ('til next time!)
Logged