VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: 'at' behaves strange  (Read 1818 times)

Pita

  • Vectorian
  • ****
  • Posts: 1338
'at' behaves strange
« on: January 17, 2011, 10:24:24 pm »

In my rescued VL6 box 'at' is now acting strangely.  When started it shows in the
CPU monitor a running taking a large junk of the % CPU used. It will only stop with
command 'at stop'.

I removed 'at' and reinstalled it  and nothing changed.

Any ideas how to correct?
Logged

Pita

  • Vectorian
  • ****
  • Posts: 1338
Re: 'at' behaves strange
« Reply #1 on: January 18, 2011, 08:12:04 pm »

I went around it by having cron execute 'atrun' every 15 min.  :)
« Last Edit: January 19, 2011, 10:41:49 pm by Pita »
Logged

Joe1962

  • Administrator
  • Vectorian
  • *****
  • Posts: 2499
    • Joe1962's Website
Re: 'at' behaves strange
« Reply #2 on: January 19, 2011, 05:41:55 am »

I have never actually used "at", but I remembered there was a fix a broken "at" posted back in VL6 SOHO Beta 4 days, I don't know if this is at all relevant for your issue with VL6 Std though.

The fix was to do the following as root:
Code: [Select]
touch /var/spool/atjobs/.SEQ
chmod 660 /var/spool/atjobs/.SEQ
chown daemon.daemon /var/spool/atjobs/.SEQ
chmod 640 /etc/at.deny
chown root.daemon /etc/at.deny
Logged
O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10

Pita

  • Vectorian
  • ****
  • Posts: 1338
Re: 'at' behaves strange
« Reply #3 on: January 19, 2011, 10:57:05 pm »

I have never actually used "at", but I remembered there was a fix a broken "at" posted back in VL6 SOHO Beta 4 days, I don't know if this is at all relevant for your issue with VL6 Std though.

The fix was to do the following as root:
Code: [Select]
touch /var/spool/atjobs/.SEQ
chmod 660 /var/spool/atjobs/.SEQ
chown daemon.daemon /var/spool/atjobs/.SEQ
chmod 640 /etc/at.deny
chown root.daemon /etc/at.deny

Nope above changed nothing. The moment I start 'at' it eats up CPU usage.

I like 'at'. It is fast. Coming from the dentist in a terminal type:

at now +6 month
enter commands like a sound, followed by xmessage for a message
then finish with
Ctrl+d

and exactly in 6 months it will remind you to go to the dentist, if that was your message.

If have tried various schedulers and never was able to figure them out
being gui challenged.

Logged