VectorLinux
April 23, 2014, 04:19:51 am *
Welcome, Guest. Please login or register.
Did you miss your activation email?

Login with username, password and session length
News: Visit our home page for VL info. To search the old message board go to http://vectorlinux.com/forum1. The first VL forum is temporarily offline until we can find a host for it. Thanks for your patience.
 
Now powered by KnowledgeDex.
   Home   Help Search Login Register  
Please support VectorLinux!
Pages: [1]
  Print  
Author Topic: 'at' behaves strange  (Read 1456 times)
Pita
Vectorian
****
Posts: 1285


« on: January 17, 2011, 10:24:24 pm »

In my rescued VL6 box 'at' is now acting strangely.  When started it shows in the
CPU monitor a running taking a large junk of the % CPU used. It will only stop with
command 'at stop'.

I removed 'at' and reinstalled it  and nothing changed.

Any ideas how to correct?
Logged
Pita
Vectorian
****
Posts: 1285


« Reply #1 on: January 18, 2011, 08:12:04 pm »

I went around it by having cron execute 'atrun' every 15 min.  Smiley
« Last Edit: January 19, 2011, 10:41:49 pm by Pita » Logged
Joe1962
Administrator
Vectorian
*****
Posts: 2498



WWW
« Reply #2 on: January 19, 2011, 05:41:55 am »

I have never actually used "at", but I remembered there was a fix a broken "at" posted back in VL6 SOHO Beta 4 days, I don't know if this is at all relevant for your issue with VL6 Std though.

The fix was to do the following as root:
Code:
touch /var/spool/atjobs/.SEQ
chmod 660 /var/spool/atjobs/.SEQ
chown daemon.daemon /var/spool/atjobs/.SEQ
chmod 640 /etc/at.deny
chown root.daemon /etc/at.deny
Logged

O'Neill (RE the Asgard): "Usually they ask nicely before they ignore us and do what they damn well please."
http://joe1962.bigbox.info
Running: VL 7 Std 64 + self-cooked XFCE-4.10
Pita
Vectorian
****
Posts: 1285


« Reply #3 on: January 19, 2011, 10:57:05 pm »

I have never actually used "at", but I remembered there was a fix a broken "at" posted back in VL6 SOHO Beta 4 days, I don't know if this is at all relevant for your issue with VL6 Std though.

The fix was to do the following as root:
Code:
touch /var/spool/atjobs/.SEQ
chmod 660 /var/spool/atjobs/.SEQ
chown daemon.daemon /var/spool/atjobs/.SEQ
chmod 640 /etc/at.deny
chown root.daemon /etc/at.deny

Nope above changed nothing. The moment I start 'at' it eats up CPU usage.

I like 'at'. It is fast. Coming from the dentist in a terminal type:

at now +6 month
enter commands like a sound, followed by xmessage for a message
then finish with
Ctrl+d

and exactly in 6 months it will remind you to go to the dentist, if that was your message.

If have tried various schedulers and never was able to figure them out
being gui challenged.

Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.19 | SMF © 2013, Simple Machines Valid XHTML 1.0! Valid CSS!