VectorLinux

Please login or register.

Login with username, password and session length
Advanced search  

News:

Visit our home page for VL info. For support and documentation, visit the Vector Linux Knowledge Center or search the Knowledge Center and this Forum using the search box above.

Author Topic: google chrome: zlib and nss errors  (Read 2889 times)

Daniel

  • Packager
  • Vectorian
  • ****
  • Posts: 704
    • TuxToys - Packages for VectorLinux 6.0
google chrome: zlib and nss errors
« on: January 23, 2011, 06:30:52 pm »

Google Chrome now fails to start when I click on the icon. I started it from the terminal to see the error messages and I got these:

/usr/bin/google-chrome: /usr/lib/libz.so.1: no version information available (required by /usr/bin/google-chrome)
/usr/bin/google-chrome: /usr/lib/libz.so.1: no version information available (required by /usr/bin/google-chrome)
/usr/bin/google-chrome: /opt/google/chrome/libnss3.so.1d: version `NSS_3.12.3' not found (required by /usr/bin/google-chrome)
/usr/bin/google-chrome: /opt/google/chrome/libnss3.so.1d: version `NSS_3.12' not found (required by /usr/bin/google-chrome)

I have tried reinstalling mozilla-nss and zlib. I also updated Google Chrome. Nothing has worked so far. I think it started doing this after I installed wine (which did something with nss I think). Does anyone know how to fix this?
Logged
The following sentence is true. The previous sentence is false.

VL 6.0 SOHO KDE-Classic on 2.3 Ghz Dual-core AMD with 3 Gigs of RAM

brokndodge

  • Member
  • *
  • Posts: 83
  • Linux is sooo HOT
    • My Blog
Re: google chrome: zlib and nss errors
« Reply #1 on: February 11, 2011, 01:26:23 pm »

i figure wine installation may have upgraded or downgraded some packages. my scripts at brokndodge.blogspot.com contain links to the correct slackware packages to run chrome. unfortunately the version numbers are hard coded into chrome so you have to have the specific version installed. just look thru my old posts for the chrome install scripts. they are pretty well commented so look for the section labeled nss.
Logged
VL 7.0 Standard

brokndodge
- OSS is not a religion, it's the solution to buggy irresponsible coding -
Linux User# 494720